openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Prud'hommeaux <mprud...@apache.org>
Subject Re: Testing an OpenJPA module
Date Mon, 09 Apr 2007 19:10:53 GMT
Matthieu-

Note that there shouldn't be any problem with running against a  
directory versus a jar (I do it all the time), so there is probably  
some environment issue.

Can you post your persistence.xml? If you write a little main()  
method that just does: System.out.println(getClass().getResource("/ 
META-INF/persistence.xml"), what does it show?



On Apr 9, 2007, at 11:54 AM, Matthieu Riou wrote:

> Hi,
>
> I'm having some difficulties testing a module that uses persistent  
> classes.
> In that case the classes aren't loaded from a jar but are directly  
> in the
> classpath and so does the persistence.xml.  However I always get "No
> Persistence provider for EntityManager named ode-store". I've tried  
> several
> things:
>
> - placing persistence.xml in a META-INF subdirectory of a directory  
> directly
> in my classpath
> - placing persistence.xml in a directory directly in my classpath
> - renaming my persistence.xml to openjpa.xml and placing its directory
> directly in my classpath
> - setting the openjpa.properties system property to the location of  
> the
> openjpa.xml
>
> None of these worked, same error message. I guess I'm missing  
> something but
> can't spot what, any idea?
>
> Thanks!
> Matthieu


Mime
View raw message