openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marina Vatkina <Marina.Vatk...@Sun.COM>
Subject Re: Open JPA error-Could not locate metadata for the class using alias
Date Thu, 26 Apr 2007 23:14:51 GMT
tbee wrote:
> 
> 
> Patrick Linskey wrote:
> 
>>I think that if you do 1, 2, 3, 5, and 6, you should be in good shape.
>>
> 
> 
> This indeed seems to work!
> 
> BTW, Toplink just now also had its lazy loading issue solved: turns out
> @MappedSuperclass classes must be listed in the persistence.xml. 

@MappedSuperclass must be listed (though providers can choose to help you there, 
the spec doesn't require them to do so) - see the spec section

6.2.1.6 mapping-file, jar-file, class, exclude-unlisted-classes

The following classes must be implicitly or explicitly denoted as managed 
persistence classes to be included within a persistence unit: entity classes; 
embeddable classes; mapped superclasses.

-marina

  The
> solution actually was unexpected, it suddenly worked, after you told me to
> do add them for the OpenJPA issue. You've solved two issues in one go! :-) 
> 
> So now I'm suddenly from no working library to two. Now to decide which one
> to use.
> 
> Many thanks Patrick!

Mime
View raw message