openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abe White <>
Subject Re: svn commit: r525997 - in /incubator/openjpa/trunk: openjpa-jdbc/src/main/java/org/apache/openjpa/jdbc/kernel/ openjpa-jdbc/src/main/java/org/apache/openjpa/jdbc/sql/ openjpa-jdbc/src/main/resources/org/apache/openjpa/jdbc/kernel/ openjpa-jdbc/src/main
Date Fri, 06 Apr 2007 19:31:53 GMT
>> Why is this setting called "IsolationLevel" where our global setting
>> is called "TransactionIsolation"?  Shouldn't this local setting just
>> be called "Isolation" for consistency?  Same with the
>> FetchPlan facade.
> Personally, I feel that 'IsolationLevel' is a more-well-known term for
> the concept. I'm fine with either name, though.

Does anyone else have an opinion on this?  I think get/setIsolation  
would be more consistent with the global TransactionIsolation  
property.  I doubt the lack of a "Level" suffix is going to hurt.

Notice:  This email message, together with any attachments, may contain information  of  BEA
Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,
 copyrighted  and/or legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient, and have received
this message in error, please immediately return this by email and then delete it.

View raw message