openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tbee <t...@tbee.org>
Subject Re: Open JPA error-Could not locate metadata for the class using alias
Date Fri, 20 Apr 2007 12:50:22 GMT



tbee wrote:
> 
> 
> 
> Jacek Laskowski-4 wrote:
>> 
>> So I read it that you're relying "on the other mechanisms" TopLink JPA
>> provides.
>> 
> 
> Ah, no, all classes are defined in the persistence.xml. In fact I turned
> autodetection explicitely off when I was trying Hibernate (OpenJPA is
> attempt 3); my persistent classes are reverse engineered from the DB and
> some metatables generate classes that cause trouble, and I explicitely
> make them non-persistent by removing them from the <class> list. Sorry.
> 

Is it possible this has to do with the way I've setup the entity classes?
What I do is have an @Entity class without any fields and it extends a
@MappedSuperclass which is generated from the DB and where all the actual
fields are declared.

package nl.reinders.bm;
@Entity
@Table(name="article")
public class Article extends nl.reinders.bm.generated.Article
{
	... almost empty...
}


package nl.reinders.bm.generated;
@MappedSuperclass
public class Article
{
	@OneToMany(mappedBy = "iArticle"...
	...
	@Column(name="description")
	private String iDescription;
	....
}

-- 
View this message in context: http://www.nabble.com/Open-JPA-error-Could-not-locate-metadata-for-the-class-using-alias-tf3561516.html#a10101376
Sent from the open-jpa-dev mailing list archive at Nabble.com.


Mime
View raw message