openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phill Moran" <pjmo...@rogers.com>
Subject RE: Duplicate query
Date Mon, 16 Apr 2007 19:29:10 GMT
I guess the question then is what does this mean, is OpenJPA (not) doing
something due to this? You see I have another error that is not representative
of some real problem that I am trying to determine and I am looking to clear
away the noise.

  _____  

From: Hans J. Prueller [mailto:hans.prueller@gmx.net] 
Sent: April 16, 2007 3:20 PM
To: open-jpa-dev@incubator.apache.org
Cc: jacek@laskowski.net.pl
Subject: Re: Duplicate query


Phill,

I am still getting the same warning - although I am using a 0.9.7-snapshot that
is some weeks old meanwhile:

160  lbsims  INFO   [RMI TCP Connection(3)-127.0.1.1] openjpa.Runtime - Starting
OpenJPA 0.9.7-incubating-SNAPSHOT
363  lbsims  INFO   [RMI TCP Connection(3)-127.0.1.1] openjpa.jdbc.JDBC -
OpenJPA will now connect to the database to attempt to determine what type of
database dictionary to use.  To prevent this connection in the future, set your
openjpa.jdbc.DBDictionary configuration property to the appropriate value for
your database (see the documentation for available values).
449  lbsims  INFO   [RMI TCP Connection(3)-127.0.1.1] openjpa.jdbc.JDBC - Using
dictionary class "org.apache.openjpa.jdbc.sql.MySQLDictionary" (MySQL
5.0.24a-Debian_9ubuntu2-log ,MySQL-AB JDBC Driver mysql-connector-java-5.0.4 (
$Date: 2006-10-19 17:47:48 +0200 (Thu, 19 Oct 2006) $, $Revision: 5908 $ )).
2180  lbsims  WARN   [RMI TCP Connection(3)-127.0.1.1] openjpa.MetaData - Found
duplicate query "PositionLog.byId" in "class
com.lbslogics.ims.model.PositionLog".  Ignoring.


As you can see, I'm prefixing the query names with the Pojo-name to avoid
duplicate names but nevertheless, the warning comes up...

Hans

Am Montag, den 16.04.2007, 15:11 -0400 schrieb Phill Moran: 

 I am still getting a duplicate query where no duplicate exists. Did this get

resolved in the 0.97 release or may this be a config issue on my part? 



Phill


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message