openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Sutter" <kwsut...@gmail.com>
Subject Re: [VOTE] Move JPA API dependency from dev.java.net to geronimo version
Date Fri, 09 Feb 2007 14:28:58 GMT
+1

Either move to the Geronimo version or get the dev.java version updated.
Either way, just so that we're using a spec-compliant version of the API.
Thanks!

Kevin

On 2/8/07, Marc Prud'hommeaux <mprudhom@apache.org> wrote:
>
>
> It turns out that the JPA API we've been building against (the one
> from https://maven-repository.dev.java.net/repository/
> javax.persistence/jars/persistence-api-1.0.jar) is not actually the
> final version of the spec: there are some minor (and binary-
> compatible) changes (some annotations don't have runtime retention,
> for example), but they are enough to prevent us from passing all the
> compatibility tests we need.
>
> The Geronimo API jar (http://mirrors.ibiblio.org/pub/mirrors/maven2/
> org/apache/geronimo/specs/geronimo-jpa_3.0_spec/geronimo-
> jpa_3.0_spec-1.0.jar) is compliant, as far as I can tell.
>
> How do people feel about changing the dependency from persistence-
> api-1.0.jar to geronimo-jpa_3.0_spec-1.0.jar? I've run through all
> our tests, and they pass with the Geronimo version. This would have
> the added advantage of unifying our spec jars to all be using the
> Geronimo versions.
>
> +1 indicates that you approve of the change
> -1 indicated that you disagree that the change should be made
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message