openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matthieu.r...@gmail.com>
Subject Re: Using _attributes
Date Mon, 15 Jan 2007 17:04:17 GMT
I see. I specifically had problems with relation tables though. I had
columns generated as _attribute_OTHERTABLENAME and the first _ didn't make
it through Derby. Hence the necessary usage of @ElementJoinColumn.

Are these mandated by the spec as well?

On 1/15/07, Abe White <awhite@bea.com> wrote:
>
> > I think it could be nicer and a bit easier if OpenJPA was
> > automatically
> > eliminating the first _ from attribute names to build its default
> > coumn
> > names, don't you think?
>
> The default column names are mandated by the JPA specification.  And
> unless you're using OpenJPA-specific mappings, you shouldn't have to
> use OpenJPA-specific annotations just to rename columns.  The JPA
> spec includes standard annotations for naming the columns in all
> standard mappings.
> _______________________________________________________________________
> Notice:  This email message, together with any attachments, may contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> entities,  that may be confidential,  proprietary,  copyrighted  and/or
> legally privileged, and is intended solely for the use of the individual
> or entity named in this message. If you are not the intended recipient,
> and have received this message in error, please immediately return this
> by email and then delete it.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message