openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Sutter" <kwsut...@gmail.com>
Subject Re: log create table statements?
Date Wed, 31 Jan 2007 14:33:50 GMT
Another possibility is that you need to explicitly declare the classes that
you want processed for automatic table creation via the <class>..</class>
elements.  Scanning for available Entity classes won't work when attempting
to auto create the tables.

Kevin

On 1/30/07, Marc Prud'hommeaux <mprudhom@apache.org> wrote:
>
> Dain-
>
> Odd ... you certainly should see the statements. Are you sure you
> aren't running against a database where the tables already exist
> (since OpenJPA won't try to create tables when they exist)?
>
> Can you see any SQL statements in the logged messages at all (e.g.,
> when you run a query)? Can you post the logging output? (I want to
> make sure the log setting is not being overridden somewhere else).
>
>
>
> On Jan 30, 2007, at 3:30 PM, Dain Sundstrom wrote:
>
> > I have openjpa setup to auto create my tables, and I see openjpa
> > the tables using in my log, but I don't see the create table
> > statements.  I have this in my persistenc.xml file
> >
> >     <properties>
> >         <property name="openjpa.Log" value="DefaultLevel=TRACE"/>
> >         <property name="openjpa.jdbc.SynchronizeMappings"
> > value="buildSchema(ForeignKeys=true)"/>
> >     </properties>
> >
> > I there some other property I need to set?
> >
> > -dain
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message