openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Sutter" <kwsut...@gmail.com>
Subject Re: Deadlock when insert in t1 and find in t2
Date Mon, 08 Jan 2007 19:01:01 GMT
Hi Vlad,
Can you provide a bit more information?  Are you running in a managed
environment or a standalone environment?  Are these JTA transactions or
Local transactions?  What does your test program look like?  What about the
Entities?  Maybe you can attach them to your next reply?

I see that you are using the J9 JVM.  I haven't tried that yet.  I've been
using the "standard" IBM JVM 1.5 at SR3 (or above).  I doubt that this would
make a different, but it might be useful to try this JVM as a test.

What you are describing is basic JPA functionality, so there must be
something unique with your application or environment.

Thanks,
Kevin

On 1/8/07, Vlad Tatavu <vtatavu@ca.ibm.com> wrote:
>
> I have a simple test program that uses OpenJPA 0.9.6 to insert an object
> into a db in one transaction (t1) and retrieve it in another transaction
> (t2).  The program hangs in 30-50% of the executions right before the call
> to entitymanager.find() (used to retrieve the object in t2).  By looking
> at the JVM dump, I can see the following deadlock:
> 1LKDEADLOCK    Deadlock detected !!!
> NULL           ---------------------
> NULL
> 2LKDEADLOCKTHR  Thread "main" (0x0015EC00)
> 3LKDEADLOCKWTR    is waiting for:
> 4LKDEADLOCKMON      sys_mon_t:0x41E40548 infl_mon_t: 0x41E40588:
> 4LKDEADLOCKOBJ      java/lang/Object@00D41010/00D4101C:
> 3LKDEADLOCKOWN    which is owned by:
> 2LKDEADLOCKTHR  Thread "Finalizer thread" (0x41B36200)
> 3LKDEADLOCKWTR    which is waiting for:
> 4LKDEADLOCKMON      sys_mon_t:0x0035CD38 infl_mon_t: 0x0035CD78:
> 4LKDEADLOCKOBJ      sun/misc/Launcher$AppClassLoader@00D4E5B0/00D4E5BC:
> 3LKDEADLOCKOWN    which is owned by:
> 2LKDEADLOCKTHR  Thread "main" (0x0015EC00)
>
> I'm using IBM JVM 5 (J2RE 5.0 IBM J9 2.3 Windows XP x86-32 build
> j9vmwi3223-20061001) and OpenJPA Runtime Enhancement.
>
> Is this a known issue?
>
> I can provide the test program, persistence.xml, etc.
>
> --
> Best regards,
> Vlad Tatavu
> Provisioning & Orchestration Development, IBM Tivoli Toronto
> vtatavu@ca.ibm.com
> Office (905) 413-3853
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message