openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dain Sundstrom <d...@iq80.com>
Subject Re: Debugger Not Working?
Date Sun, 31 Dec 2006 17:28:43 GMT

On Dec 31, 2006, at 12:04 AM, Marc Prud'hommeaux wrote:

> I've never experienced this problem, but as a guess, are you  
> running with dynamic enhancement (using the "-javaagent" flag)? If  
> so, what happens if you enhance manually, and then run without the  
> agent flag?

Currently, I am, but I can recreate the problem without it, it just  
takes a lot longer.  Actually, it seems be related to the amount of  
code executed.  If I run the Agent and it enhances, that is a lot of  
code executed and the problem happens quickly.  If I run derby  
instead of HSQLDB, it happens quickly.  It is very strange.

> Also, you could always try running "javastack" on a process (found  
> using "jps") from a console and see if you get a stack trace from  
> that.

I'll try that.

-dain

Mime
View raw message