openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Prud'hommeaux <mprud...@apache.org>
Subject Re: JTA 1.1 has been published
Date Sat, 28 Oct 2006 03:49:01 GMT

> IIRC, the Geronimo jars are compiled with a later version of the JDK.

That does appears to be correct:

[20:44 chance mprudhom]$ java -cp ~/.m2/repository/org/apache/ 
geronimo/specs/geronimo-jta_1.0.1B_spec/1.0.1/geronimo- 
jta_1.0.1B_spec-1.0.1.jar javax.transaction.SystemException
Exception in thread "main" java.lang.UnsupportedClassVersionError:  
javax/transaction/SystemException (Unsupported major.minor version 48.0)
         at java.lang.ClassLoader.defineClass0(Native Method)


Not a big problem for the whole OpenJPA project per se (since we  
require 1.5 in order to support javax.persistence anyway), but if  
someone were to want to depend on the 1.3 portions of the OpenJPA  
Broker for their own persistence engine, then they wouldn't be able  
to transitively rely on the Geronimo jars.



On Oct 27, 2006, at 8:32 PM, Craig L Russell wrote:

> Does anyone have any comments on this point?
>
>>> The library was compiled with JDK 1.3 so it can be used with any  
>>> of the openjpa libraries.
>>>
> IIRC, the Geronimo jars are compiled with a later version of the JDK.
>
> Craig
>
> Craig Russell
> clr@apache.org http://db.apache.org/jdo
>
>


Mime
View raw message