openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roytman, Alex" <Roytm...@peacetech.com>
Subject RE: Kodo 4.1 does not include open JPA sources?
Date Fri, 13 Oct 2006 20:14:58 GMT
Thank you very much Mark!

What version of Serp is bundled with Kodo? I need to get sources because
the error I am seeing is in serp's String.toClass()

Alex

-----Original Message-----
From: Marc Prud'hommeaux [mailto:mprudhomapache@gmail.com] On Behalf Of
Marc Prud'hommeaux
Sent: Friday, October 13, 2006 3:43 PM
To: open-jpa-dev@incubator.apache.org
Subject: Re: Kodo 4.1 does not include open JPA sources?

Alex-

Kodo 4.1 is based on the "openjpa-0.9.0-incubating" release. You can  
download the source from:

    http://cwiki.apache.org/openjpa/downloads.html

Also, running "java kodo.conf.KodoVersion" will output the exact  
OpenJPA version and the svn revision number that it was based on.


On Oct 13, 2006, at 12:37 PM, Roytman, Alex wrote:

> Hello,
>
>
>
> Is there any reason openjpa sources are not included with Kodo 4.1?
> Since we do not know which SVN version is included with Kodo we can  
> not
> get it from SVN either. If we had it, it would help analyzing problems
> and reporting issues properly.
>
>
>
> For example while trying to run 3.x Kodo app under 4.1 I got
>
>
>
> Caused by: org.xml.sax.SAXException:
> file:/D:/projects/peacetech-products/dts/jdo/classes/com/peacetech/ 
> dts/j
> do/package.jdo [Location: Line: 145, C: 76]: Type
> "com.peacetech.dts.jdo.ContentFieldImpl" could not be instantiated.
>
>             at
> org.apache.openjpa.lib.meta.XMLMetaDataParser.getException 
> (XMLMetaDataPa
> rser.java:649)
>
>             at
> org.apache.openjpa.lib.meta.CFMetaDataParser.classForName 
> (CFMetaDataPars
> er.java:282)
>
>             at
> kodo.jdo.JDOMetaDataParser.classForName(JDOMetaDataParser.java:1990)
>
>             at
> kodo.jdo.JDOMetaDataParser.setElementMetaDataAttributes 
> (JDOMetaDataParse
> r.java:1188)
>
>             at
> kodo.jdo.JDOMetaDataParser.startCollection(JDOMetaDataParser.java: 
> 1216)
>
>             at
> kodo.jdo.JDOMetaDataParser.startClassElement(JDOMetaDataParser.java: 
> 767)
>
>             at
> org.apache.openjpa.lib.meta.CFMetaDataParser.startElement 
> (CFMetaDataPars
> er.java:104)
>
>             at
> org.apache.openjpa.lib.meta.XMLMetaDataParser.startElement 
> (XMLMetaDataPa
> rser.java:426)
>
>
>
>
>
> This stack trace does not have exception which caused it so I have no
> idea what's the problem is. I only know that under 3.4 it runs fine.
>
>
>
>
>
> Thank you very much
>
>
>
> Alex Roytman
>
> Peace Technology, Inc.
>
> 301-206-9696x103
>
>
>


Mime
View raw message