openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Prud'hommeaux <mprud...@apache.org>
Subject Re: doxia-sink-api POM problem
Date Fri, 25 Aug 2006 22:33:57 GMT

Yay! Glad you got it working.


On Aug 25, 2006, at 3:29 PM, Marc Logemann wrote:

> Yeah you are correct. I copied the other two german props files  
> manually in my build/compile path of my IDE but i forgot to do the  
> same for localizer.properties. Sorry. Now everything works.
>
> To be sure i also ran it via "mvn install" and there it works too.
>
> --
> regards
> Marc Logemann
> [blog] http://www.logemann.org
> [busn] http://www.logentis.de
>
>
> Am 26.08.2006 um 00:21 schrieb Marc Prud'hommeaux:
>
>> Marc-
>>
>> Hmm ... I actually think that might be a problem with your  
>> environment. Do you have access to the openjpa-lib/src/test/ 
>> resources/localizer.properties file? Is openjpa-lib/src/test/ 
>> resources/ in your Idea CLASSPATH?
>>
>> Are you able to run Maven from the console? If so, do you also get  
>> that exception when you do so?
>>
>>
>>
>>
>> On Aug 25, 2006, at 3:12 PM, Marc Logemann wrote:
>>
>>> better, but still one failed:
>>>
>>> junit.framework.ComparisonFailure:
>>> Expected :systemvalue1
>>> Actual  :test.systemlocal
>>> 	at org.apache.openjpa.lib.util.TestLocalizer.assertEquals 
>>> (TestLocalizer.java:120)
>>> 	at org.apache.openjpa.lib.util.TestLocalizer.testTopLevel 
>>> (TestLocalizer.java:76)
>>> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>> 	at sun.reflect.NativeMethodAccessorImpl.invoke 
>>> (NativeMethodAccessorImpl.java:39)
>>> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke 
>>> (DelegatingMethodAccessorImpl.java:25)
>>> 	at com.intellij.rt.execution.junit2.JUnitStarter.main 
>>> (JUnitStarter.java:32)
>>>
>>>
>>>
>>> --
>>> regards
>>> Marc Logemann
>>> [blog] http://www.logemann.org
>>> [busn] http://www.logentis.de
>>>
>>>
>>> Am 25.08.2006 um 23:35 schrieb Marc Prud'hommeaux:
>>>
>>>>
>>>> Interesting ... I would have assumed the two would be  
>>>> equivalent. Anyway, I've changed it to use equals() ... can you  
>>>> update and re-run the tests and see if it still fails?
>>>>
>>>>
>>>>
>>>> On Aug 25, 2006, at 2:16 PM, Marc Logemann wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> Unfortunately Locale.getDefault() == Locale.GERMANY  is false.  
>>>>> Didnt you mean .equals() ?
>>>>>
>>>>> --
>>>>> regards
>>>>> Marc Logemann
>>>>> [blog] http://www.logemann.org
>>>>> [busn] http://www.logentis.de
>>>>>
>>>>>
>>>>> Am 25.08.2006 um 22:59 schrieb Marc Prud'hommeaux:
>>>>>
>>>>>>
>>>>>>> Most likely i am the first non EN locale user :) Here is the
 
>>>>>>> stack
>>>>>>
>>>>>> That's exactly the problem ... the test would actually pass  
>>>>>> for any locale *except* German. I've just committed a fix ...  
>>>>>> the test should pass for you after your next update.
>>>>>>
>>>>>
>>>>
>>>
>>
>


Mime
View raw message