openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Sutter" <kwsut...@gmail.com>
Subject OpenJPA and JDK 1.4?
Date Tue, 22 Aug 2006 22:46:02 GMT
Hi,
Has there been any investigation into providing a JPA-like implementation
that would execute in the JDK 1.4 environment?  I know we have the
Java 5.0requirements for generics and enums built right into the JPA
interfaces.  I
was just wondering whether anybody has investigated "down-grading" the
interfaces and the associated implementation to support JDK 1.4.  We have
the kernel-4 sub-project, probably as a basis for the Kodo JDO support.
This would make a nice alternative to Hibernate running on 1.4...

Thoughts?

Kevin

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message