openjpa-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dwo...@apache.org
Subject svn commit: r794409 - /openjpa/trunk/openjpa-integration/validation/pom.xml
Date Wed, 15 Jul 2009 20:48:08 GMT
Author: dwoods
Date: Wed Jul 15 20:48:08 2009
New Revision: 794409

URL: http://svn.apache.org/viewvc?rev=794409&view=rev
Log:
OPENJPA-1170 Fix which validation/jpa2 spec jars and versions are pulled in by transitive
Maven depends.

Modified:
    openjpa/trunk/openjpa-integration/validation/pom.xml

Modified: openjpa/trunk/openjpa-integration/validation/pom.xml
URL: http://svn.apache.org/viewvc/openjpa/trunk/openjpa-integration/validation/pom.xml?rev=794409&r1=794408&r2=794409&view=diff
==============================================================================
--- openjpa/trunk/openjpa-integration/validation/pom.xml (original)
+++ openjpa/trunk/openjpa-integration/validation/pom.xml Wed Jul 15 20:48:08 2009
@@ -81,8 +81,13 @@
                     <artifactId>agimatec-jsr303</artifactId>
                     <version>0.9.1-SNAPSHOT</version>
                     <scope>test</scope>
-                    <!-- force usage of the geronimo-validation spec -->
                     <exclusions>
+                        <!-- force usage of the geronimo-validation_1.0_spec -->
+                        <exclusion>
+                            <groupId>javax.validation</groupId>
+                            <artifactId>validation-api</artifactId>
+                        </exclusion>
+                        <!-- use our level of the geronimo-jpa_2.0_spec -->
                         <exclusion>
                             <groupId>javax.validation</groupId>
                             <artifactId>validation-api</artifactId>
@@ -135,21 +140,27 @@
                 <dependency>
                     <groupId>javax.validation</groupId>
                     <artifactId>validation-api</artifactId>
-                    <version>1.0.CR1</version>
-                    <!-- <version>1.0.CR3-SNAPSHOT</version> -->
+                    <version>1.0.CR2</version>
+                    <!-- <version>1.0.CR3</version> -->
                     <scope>test</scope>
                 </dependency>
                 <dependency>
                     <groupId>org.hibernate</groupId>
                     <artifactId>hibernate-validator</artifactId>
-                    <version>4.0.0.Alpha3</version>
+                    <version>4.0.0.Beta1</version>
                     <!-- <version>4.0.0.Beta2-SNAPSHOT</version> -->
                     <scope>test</scope>
                     <exclusions>
+                        <!-- force usage of the geronimo-jpa_2.0_spec -->
                         <exclusion>
                             <groupId>org.hibernate.java-persistence</groupId>
                             <artifactId>jpa-api</artifactId>
                         </exclusion>
+                        <!-- force usage of the RI API level above -->
+                        <exclusion>
+                            <groupId>javax.validation</groupId>
+                            <artifactId>validation-api</artifactId>
+                        </exclusion>
                     </exclusions>
                 </dependency>
                 <dependency>
@@ -178,7 +189,6 @@
                         <enabled>true</enabled>
                     </releases>
                 </repository>
-                <!--
                 <repository>
                     <id>snapshots.jboss.org</id>
                     <name>JBoss Repository</name>
@@ -191,7 +201,6 @@
                         <enabled>false</enabled>
                     </releases>
                 </repository>
-                -->
             </repositories>
         </profile>
     </profiles>
@@ -201,6 +210,13 @@
             <groupId>org.apache.openjpa</groupId>
             <artifactId>openjpa</artifactId>
             <version>${pom.version}</version>
+            <!-- allow profiles to decide which validation spec to use -->
+            <exclusions>
+                <exclusion>
+                    <groupId>org.apache.geronimo.specs</groupId>
+                    <artifactId>geronimo-validation_1.0_spec</artifactId>
+                </exclusion>
+            </exclusions>
         </dependency>
         <dependency>
             <groupId>org.apache.openjpa</groupId>



Mime
View raw message