openejb-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bjorn Danielsson <>
Subject Re: Number of simultaneous @Asynchronous threads
Date Mon, 20 Aug 2012 14:16:17 GMT
I built from the latest source (r1374989) and tried the new
configuration, but I get strange errors. Just by placing the
default values in in a freshly unpacked
TomEE-plus, I got this exception:

INFO: Assembling app: openejb
Aug 20, 2012 3:56:28 PM org.apache.openejb.util.OptionsLog info
INFO: Using 'AsynchronousPool.CorePoolSize=10'
Aug 20, 2012 3:56:28 PM org.apache.openejb.util.OptionsLog info
INFO: Using 'AsynchronousPool.MaximumPoolSize=20'
Aug 20, 2012 3:56:28 PM org.apache.openejb.util.OptionsLog info
INFO: Using 'AsynchronousPool.KeepAliveTime=60'
Aug 20, 2012 3:56:28 PM org.apache.openejb.assembler.classic.Assembler destroyApplication
INFO: Undeploying app: openejb
Aug 20, 2012 3:56:29 PM org.apache.openejb.assembler.classic.Assembler buildContainerSystem
SEVERE: Application could not be deployed:  openejb
org.apache.openejb.OpenEJBException: Creating application failed: openejb: null
        at org.apache.openejb.assembler.classic.Assembler.createApplication(
        at org.apache.openejb.assembler.classic.Assembler.createApplication(
        at org.apache.openejb.assembler.classic.Assembler.buildContainerSystem(
        at org.apache.openejb.OpenEJB$Instance.<init>(
        at org.apache.openejb.OpenEJB.init(
        at org.apache.tomee.catalina.TomcatLoader.initialize(
        at org.apache.tomee.catalina.TomcatLoader.init(
        at org.apache.tomee.catalina.ServerListener.lifecycleEvent(
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(
        at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(
        at org.apache.catalina.util.LifecycleBase.setStateInternal(
        at org.apache.catalina.util.LifecycleBase.init(
        at org.apache.catalina.startup.Catalina.load(
        at org.apache.catalina.startup.Catalina.load(
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at org.apache.catalina.startup.Bootstrap.load(
        at org.apache.catalina.startup.Bootstrap.main(
Caused by: java.lang.NullPointerException
        at java.util.concurrent.ThreadPoolExecutor.<init>(
        at java.util.concurrent.ThreadPoolExecutor.<init>(
        at org.apache.openejb.async.AsynchronousPool.<init>(
        at org.apache.openejb.async.AsynchronousPool.create(
        at org.apache.openejb.assembler.classic.Assembler.createApplication(
        ... 20 more

I also tried deploying my webapp and moved the properties to
WEB-INF/, and that produced a similar
exception with the same cause, but for my app instead of openejb
and with some differences in the lifecycle call chain.

Björn Danielsson
Cuspy Code AB

Romain Manni-Bucau <> wrote:
> FYI, with last David refactoring the config is a bit different from the one
> i did, just to keep a track in this thread (jira is up to date), properties
> are and can be put in (META-INF or WEB-INF):
> AsynchronousPool.CorePoolSize
> AsynchronousPool.MaximumPoolSize
> AsynchronousPool.KeepAliveTime
> *Romain Manni-Bucau*
> *Twitter: @rmannibucau*
> *Blog:*
> 2012/8/20 zeeman <>
>> Great, thanks.
>> --
>> View this message in context:
>> Sent from the OpenEJB User mailing list archive at

View raw message