openejb-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: NoModulesFoundException - Problem
Date Thu, 16 Aug 2012 14:27:34 GMT
Deployment works too (was just easier to test locally to get rid of it ;)

@Inject needs to get a META-INF/beans.xml (even empty) you didn't provided
in your jars. Moreover i'm not sure it works (or should be used) since you
ask an injection of another application and i think today this scope is
badly defined by cdi.

- Romain


2012/8/16 snblim <snblim@gmail.com>

> Ha you're right! No it works like a charm :-)
> (I had to remove the line:
>
> in the openejb.xml)
>
>
> Still I've got to ask two more questions:
> 1. Shouldn't the  do the same? Is there a particular reason why the
> module-files have to be iserted as properties?
>
> 2. When do not follow your way and leave the mentioned line in the
> openejb.xml than I get the error using while @Inject or
> ContextInitial.lookup(....) - but it works when I use the @EJB
> annotation...
>
> If there is documentation that explain these issues a hint would be awesome
> :-)
>
> Anyway - thanks very much!
> Cheers
>
>
>
> --
> View this message in context:
> http://openejb.979440.n4.nabble.com/NoModulesFoundException-Problem-tp4656614p4656882.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message