openejb-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: Strange MDB invocation behavior
Date Sat, 11 Aug 2012 15:14:49 GMT
yep, check AMQ looks like a kind of hibernation

can be a network issue too, no? then it fails and recover but you lost one
message

- Romain


2012/8/11 almos <almos@ukr.net>

> Not exactly.
>
> System is running all the time. When users are doing some particular
> actions
> we use to send JMS messages  and everything works fine in 99.9% of cases.
>
> After off hours (absolutely no activity at all for about 4-6 hours from the
> users) where the are no requests and hence JMS invocations, first JMS
> message delivery to the topic doesn't occur.
>
> In other words after about of 4-6 hours of inactivity, first user comes to
> the system, does some action that triggers JMS message send operation and
> that message doesn't get delivered to the MDB listeners.
> All subsequent messages send via the system successfully delivered without
> any other efforts done to the application (no shutdown/re-deploy).
> In logs there are no exceptions and any other suspicious things. So the
> only
> one message is lost after off hours (inactivity) and then system works as
> expected till next off hours period after which we face the same 1-st
> message loss problem.
>
> I'll check ability to send via broker managemet console as well, thanks for
> the suggestion.
>
> Regards,
> Alex
>
>
>
> --
> View this message in context:
> http://openejb.979440.n4.nabble.com/Strange-MDB-invocation-behavior-tp4656801p4656803.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message