openejb-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From snblim <snb...@gmail.com>
Subject NoModulesFoundException - Problem
Date Wed, 01 Aug 2012 12:41:15 GMT
Hi forum, 

we're using OpenEJB in a project with multiple modules. These modules have
access to different databases. The projects/modules relations work in a tree
hierarchy and the
root module triggers its childs and so on. We're using no server. We need an
application that is going to be triggered with cron.

Everything works perfectly fine when running the project in eclipse. The
problem appears after exporting the project. We use the OpenEJB directory
layout (and libraries) that is
meant to be used for the standalone server - only without a server. 

We export all project (aka modules) to single jars. The modules that act as
libraries are included to lib/ and the root-module with the main method is
put in apps/. 

Than we use the following script (see 1.) to load all libraries into the
context and
to start the application (passing all parameters that are used in the
eclipse run configuration). The EJBContainer is being loaded but the process
ends because of missing/invalid modules (see log 2.). 

We cannot use the eclipse-function 'Export Runnable Jar' because our
testing-environment is included that way - for that reason we are trying to
'filter' everything unnecessary. 

I didn't post any code because I don't think it's a source-code problem
(else the problem would appear when starting from the IDE, right?). But
I'll post anything if it is necessary!

Thank you really a lot for taking your time - we're stucked with this issue
for quite a while now :-(
Cheers

The above referenced snippets:
(Some paths or names may appear strange. This xy-censoring is necessary
because of our policies.)

1.


2. (I filtered some of the 'healthy' looking INFO-lines. Here you can find
the complete log: http://pastebin.com/Kyz8jxcV)





--
View this message in context: http://openejb.979440.n4.nabble.com/NoModulesFoundException-Problem-tp4656614.html
Sent from the OpenEJB User mailing list archive at Nabble.com.

Mime
View raw message