openejb-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Louis MONTEIRO <jeano...@gmail.com>
Subject Re: Jar not loaded: Unknown module type
Date Thu, 10 Feb 2011 10:07:25 GMT

when deploying your jar into my tomcat + openejb, i get

2011-02-10 10:48:57,387 - INFO  - Configuring enterprise application:
D:\javatools\tomcat\apache-tomcat-6.0.29-openejb-3.1.4\webapps\richtestejb.jar
2011-02-10 10:48:57,418 - INFO  - Auto-linking resource-ref
'jdbc/MySqlDataSource' in bean RichTestEJBBean to Resource(id=My DataSource)
2011-02-10 10:48:57,418 - INFO  - Auto-linking resource-ref 'RichTestJPA' in
bean RichTestEJBBean to Resource(id=My DataSource)
2011-02-10 10:48:57,418 - INFO  - Configuring
PersistenceUnit(name=RichTestJPA,
provider=org.eclipse.persistence.jpa.PersistenceProvider)
2011-02-10 10:48:57,418 - INFO  - Adjusting PersistenceUnit RichTestJPA
<jta-data-source> to Resource ID 'My DataSource' from 'MySqlDataSource'
2011-02-10 10:48:57,418 - INFO  - Adjusting PersistenceUnit RichTestJPA
<non-jta-data-source> to Resource ID 'My Unmanaged DataSource' from 'null'
2011-02-10 10:48:57,418 - INFO  - Configuring
PersistenceUnit(name=RichTestLocal,
provider=org.eclipse.persistence.jpa.PersistenceProvider)
2011-02-10 10:48:57,418 - INFO  - Adjusting PersistenceUnit RichTestLocal
<jta-data-source> to Resource ID 'My DataSource' from 'null'
2011-02-10 10:48:57,418 - INFO  - Adjusting PersistenceUnit RichTestLocal
<non-jta-data-source> to Resource ID 'My Unmanaged DataSource' from 'null'
2011-02-10 10:48:57,418 - INFO  - Enterprise application
"D:\javatools\tomcat\apache-tomcat-6.0.29-openejb-3.1.4\webapps\richtestejb.jar"
loaded.
2011-02-10 10:48:57,418 - INFO  - Assembling app:
D:\javatools\tomcat\apache-tomcat-6.0.29-openejb-3.1.4\webapps\richtestejb.jar
2011-02-10 10:49:00,059 - INFO  - PersistenceUnit(name=RichTestJPA,
provider=org.eclipse.persistence.jpa.PersistenceProvider) - provider time
2638ms
2011-02-10 10:49:00,075 - INFO  - PersistenceUnit(name=RichTestLocal,
provider=org.eclipse.persistence.jpa.PersistenceProvider) - provider time
9ms
2011-02-10 10:49:00,106 - INFO  - Jndi(name=RichTestEJBBeanLocal) -->
Ejb(deployment-id=RichTestEJBBean)
2011-02-10 10:49:00,121 - INFO  - Created Ejb(deployment-id=RichTestEJBBean,
ejb-name=RichTestEJBBean, container=My Stateless Container)
2011-02-10 10:49:00,121 - INFO  - Deployed
Application(path=D:\javatools\tomcat\apache-tomcat-6.0.29-openejb-3.1.4\webapps\richtestejb.jar)

So, it works for me on
- apache-tomcat-6.0.29-openejb-3.1.4
- openejb-tomee-tomcat6-3.2-20110128.141036-1

When invoking #getDescrizioni() from the bean, i get an exception because
table does not exist.

So may be, it's a problem of configuration.
I can push my distribution if you want to give it a try.

Otherwise, can you check your installation please?
http://openejb.apache.org/3.0/tomcat.html
http://openejb.apache.org/3.0/tomcat-installation.html


Jean-Louis


-- 
View this message in context: http://openejb.979440.n4.nabble.com/Jar-not-loaded-Unknown-module-type-tp3297019p3298850.html
Sent from the OpenEJB User mailing list archive at Nabble.com.

Mime
View raw message