openejb-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: MDB
Date Thu, 14 Aug 2008 05:51:08 GMT

On Aug 13, 2008, at 12:52 PM, lupu.slobodu wrote:

> I had the activemq jars in my web application also(WebContent/WEB- 
> INF/lib).
> As soon as I took them out, it works fine.
> Sorry to have you spend time on this...

No problem.  This is a good note for the lists.  I bet we could scan  
the webapp classloader and look for issues like this.  Not sure we can  
get it in for the next release, but I bet that might be a useful  
timesaver.

-David

> David Blevins wrote:
>>
>>
>> On Aug 11, 2008, at 10:29 AM, lupu.slobodu wrote:
>>
>>>
>>> Trying to run the MDB sample form
>>> http://svn.apache.org/viewvc/openejb/trunk/openejb3/examples/simple-mdb-with-descriptor/?pathrev=678070
>>>
>>> It looks up the ConnectionFactory but it crashes when calling
>>> connectionFactory.createConnection();
>>>
>>> javax.jms.JMSException: Could not create Transport. Reason:
>>> java.io.IOException: Transport scheme NOT recognized: [vm]
>>> .
>>> .
>>> .
>>> Caused by: java.lang.ClassCastException:
>>> org.apache.activemq.transport.vm.VMTransportFactory cannot be cast  
>>> to
>>> org.apache.activemq.transport.TransportFactory
>>
>> I'm unable to get this error, but I suspect that there might have  
>> been
>> an issue with the maven 2 snapshot repository.  I cleaned it out and
>> rebuilt it and think things might be better now.
>>
>> I ran the example successfully with a completely clean repo like so:
>>
>> $ cd examples/simple-mdb-with-descriptor
>> $ mkdir temp-repo
>> $ mvn clean install -Dmaven.repo.local=temp-repo
>>
>> Everything downloaded fine and the example ran without issues.
>>
>> -David
>>
>>
>>
>
> -- 
> View this message in context: http://www.nabble.com/MDB-tp18930176p18970017.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.
>
>


Mime
View raw message