openejb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Gallimore <jonathan.gallim...@gmail.com>
Subject Re: Current tasks and status
Date Tue, 11 Jan 2011 00:04:06 GMT
I've attached a patch, which seems to work for me. What do you think?

Jon

On 10/01/2011 22:22, Jonathan Gallimore wrote:
> I had a quick look at this - looks like the Pojo webservice isn't 
> deployed at all.  Line 280 of WsSerrvice does this:
>
> WebContext webContext = containerSystem.getWebContext(webApp.moduleId);
> if (webContext == null) return;
>
> Unfortunately, the webcontext hasn't been pushed with 
> containerSystem.addWebDeployment() at this point - its invoked by 
> Assembler.createApplication(), which in turn is called by 
> TomcatWebAppBuilder.start(), line 311. The web deployment is updated 
> in the container system later in this method (line 347).
>
> Looks like this used to be done by TomcatWebAppBuilder.afterStart(). 
> Perhaps we could defer the 
> Assembler.fireAfterApplicationCreated(appInfo) call to 
> TomcatWebAppBuilder.afterStart when we're running in Tomcat? What do 
> you think?
>
> Jon
>
> On 10/01/2011 13:23, Jonathan Gallimore wrote:
>> Jean-Louis,
>>
>> Thanks for getting that in. I'll have a go with it this evening. If 
>> you can look at the webservice stuff that would be great - my guess 
>> is its something in TomcatWebAppBuilder or TomcatWsRegistry, but I 
>> imagine you'll be able to figure it out quicker than I can!
>>
>> Cheers
>>
>> Jon
>>
>> On 10/01/2011 13:08, Jean-Louis MONTEIRO wrote:
>>> Jon,
>>>
>>> All committed!
>>> If you want, i can try looking at WebService stuff?
>>>
>>> BTW, i tested under Tomcat 6.0.24
>>>
>>> Jean-Louis
>>
>


Mime
View raw message