openejb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacek Laskowski <ja...@laskowski.net.pl>
Subject Re: For adventurous: first run of OSGified OpenEJB *seems* running fine
Date Wed, 28 Oct 2009 00:25:45 GMT
On Wed, Oct 28, 2009 at 12:42 AM, Mohammad Nour El-Din
<nour.mohammad@gmail.com> wrote:

> -> ERROR: Error starting
> file:C:\Users\mnour\.m2\repository\org\apache\openejb\openejb-core\3.1.2-SNAPSHOT\openejb-core-3.1.2-SNAPSHOT.jar
> (org.osgi.framework.BundleException: Unresolved constraint in bundle
> org
> .apache.geronimo.components.geronimo-transaction [21]: package;
> (&(package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0))))
> org.osgi.framework.BundleException: Unresolved constraint in bundle
> org.apache.geronimo.components.geronimo-transaction [21]: package;
> (&(package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0)))
>        at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3263)
>        at org.apache.felix.framework.Felix.startBundle(Felix.java:1597)
>        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1077)
>        at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
>        at java.lang.Thread.run(Thread.java:619)

Doh, I don't know why I missed it in my initial email, but you need to
install OPS4J Pax Logging - API (1.4) as well. Sorry for wasting your
time. Do the following in the console of Felix.

install http://repo2.maven.org/maven2/org/ops4j/pax/logging/pax-logging-api/1.4/pax-logging-api-1.4.jar

In such cases where a package is missing, it's more helpful to have
'ps' or 'inspect package requirement <id>' output.

Jacek

-- 
Jacek Laskowski
Notatnik Projektanta Java EE - http://www.JacekLaskowski.pl

Mime
View raw message