openejb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacek Laskowski <ja...@laskowski.net.pl>
Subject Re: For adventurous: first run of OSGified OpenEJB *seems* running fine
Date Sun, 25 Oct 2009 13:55:25 GMT
On Sun, Oct 25, 2009 at 12:17 PM, Mohammad Nour El-Din
<nour.mohammad@gmail.com> wrote:
> Hi Jacek...
>
>   Now I started to use Java 6.0 but I got the following error :(.
> Notice that I attached the "default.properties" file I have in my
> "felix.jar"

The attached default.properties doesn't have javax.transaction.xa
commented out. Make sure it is (I'm not sure if it's the root cause,
but just to be on the safe side give it a try).

Execute

inspect package requirement 6

in the felix shell. 6 is the identifier of the Apache OpenEJB ::
Container :: Core (3.1.2.SNAPSHOT) in your case.

Execute

inspect package capability 0

Send both outputs so I can hunt down the issue with enough info. I
can't figure out where the version of javax.transaction came from.

Execute

-> inspect package capability 7
org.apache.geronimo.specs.geronimo-jta_1.1_spec [7] exports packages:
---------------------------------------------------------------------
javax.transaction.xa; version=1.1.0
javax.transaction; version=1.1.0

and send it as well. I'm pretty sure the identifier of the
org.apache.geronimo.specs.geronimo-jta_1.1_spec bundle is different in
the configuration I'm working with.

Jacek

-- 
Jacek Laskowski
Notatnik Projektanta Java EE - http://www.JacekLaskowski.pl

Mime
View raw message