oozie-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Richelson <drichel...@tendrilinc.com>
Subject Re: Purge Service not working
Date Thu, 13 Sep 2012 20:56:10 GMT
Thanks for the response- I think at this point I will just set up a
cron job to run a mysql query to truncate the tables based on date..
Do you mind sending it over?

Dan

On Thu, Sep 13, 2012 at 1:42 PM, Miguel Lucero
<Miguel.Lucero@apollogrp.edu> wrote:
> Hey, Dan...
>
> I had this issue with oozie in CDH3 and I think the recommendation is to upgrade to your
version :-). Our oozie instance wasn't purging records from WF_JOBS/WF_ACTIONS in our mysql
instance and the records started piling up. Everything in the config appeared to be correct
also so I attributed this to a possible bug in our version and ended up manually purging the
records. I just couldn't get the purge service to clear those jobs/actions out using any of
the oozie service settings...
>
> One thing to keep in mind is that oozie won't clear out workflow jobs/actions that are
still associated with an actively running coordinator. If it's available to you, try killing
and restarting any long running coordinators you might have and in theory oozie should go
through and purge any of the associated wf jobs/actions. We tried this but could not get purge
service to function properly...
>
> Try killing and restarting your coords to see if that triggers it... if it doesn't, then
we might be seeing a similar bug and I can post the query to truncate WF_JOBS/WF_ACTIONS that
I used as a workaround...
>
> Thanks
> Miguel
>
>
>
> -----Original Message-----
> From: Dan Richelson [mailto:drichelson@tendrilinc.com]
> Sent: Wednesday, September 12, 2012 3:33 PM
> To: user@oozie.apache.org
> Subject: Purge Service not working
>
> I have Oozie CDH4 (3.1.x plus some patches) running using a local mysql datastore.
>
> Here are the relevant properties pasted from the Oozie UI's System Info tab:
>
> oozie.service.PurgeService.purge.limit 1000 oozie.service.PurgeService.coord.older.than
7 oozie.service.PurgeService.older.than 30 oozie.service.PurgeService.bundle.older.than 7
oozie.service.PurgeService.purge.interval 3600
>
> A search of Oozie logs shows no mention of the purge service kicking in, and I still
have over 10,000 workflow jobs showing up in the UI dating back 2+ months.
>
> Any ideas on how to get the purge service to start purging?
>
> thanks
> Dan
>
>
> --
> Dan Richelson, Software Engineer
>
> Tendril
> 2560 55th St. | Boulder, Colorado 80301
> M 303-709-2214
> www.tendrilinc.com
>
> This email and any files transmitted with it are confidential and intended solely for
the use of the individual or entity to whom they are addressed.
> If you have received this email in error please notify the sender.
> Please note that any views or opinions presented in this email are solely those of the
author and do not necessarily represent those of the company.
> Finally, the recipient should check this email and any attachments for the presence of
viruses.
> The company accepts no liability for any damage caused by any virus transmitted by this
email.
>
>
>
> This message is private and confidential. If you have received it in error, please notify
the sender and remove it from your system.
>
>



-- 
Dan Richelson, Software Engineer

Tendril
2560 55th St. | Boulder, Colorado 80301
M 303-709-2214
www.tendrilinc.com
 
This email and any files transmitted with it are confidential and intended solely for the
use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the sender.
Please note that any views or opinions presented in this email are solely those of the author
and do not necessarily represent those of the company.
Finally, the recipient should check this email and any attachments for the presence of viruses.
The company accepts no liability for any damage caused by any virus transmitted by this email.


Mime
View raw message