oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Mattmann <mattm...@apache.org>
Subject Re: Problem with Zookeeper-config feature in development branch
Date Wed, 11 Oct 2017 17:00:15 GMT
Thanks Imesha, appreciate it. I think there is more going on with the 2nd test 
though. I think it has to do with the workflow manager not being able to read 
system properties from the distributed configuration. That test hasn’t failed in
years, and it has always read the needed properties from the workflow.properties
file locally. My guess is that the test is failing due to distributed configuration reading.
Can you double check? Or perhaps property files were moved?

Cheers,
Chris




On 10/11/17, 6:06 AM, "Imesha Sudasingha" <imesha.13@cse.mrt.ac.lk> wrote:

    Hey Chris,
    
    The problem was with maven surefire plugin which had <forkMode> set to
    "never". Changed it to "perTest" which solved majority of the cases. I
    fixed it and sent a PR. please merge it to development if you feel ok. That
    PR include some changes in zookeeper module as well.
    
    Still there is an NPE in
    "org.apache.oodt.cas.workflow.repository.DataSourceWorkflowRepositoryFactory"
    at line 68. The problem there is, we are trying to use a JDBC connection
    even at the testing phase. But the property
    *org.apache.oodt.cas.workflow.repo.datasource.jdbc.driver* is always null.
    Can you look into that?
    
    Other tests are passing now.
    
    Regards,
    Imesha
    
    Kind Regards,
    *Imesha Sudasingha*
    Undergraduate of Department of Computer Science and  Engineering,
    University of Moratuwa,
    Sri Lanka.
    
    <https://lk.linkedin.com/in/imeshasudasingha>  <https://github.com/IMS94>
    <http://stackoverflow.com/users/4012073/imesha-sudasingha>
    
    On 11 October 2017 at 00:17, Chris Mattmann <mattmann@apache.org> wrote:
    
    > Hey Imesha,
    >
    > I’m working with ZK-config feature and trying to merge it into the
    > development
    > branch but running into errors related to the workflow manager tests:
    >
    > https://paste.apache.org/Vd4a
    >
    > FYI: it seems that the ZK config publishes workflow configuration here:
    > /projects/primary/components/wmgr/
    >
    > But then expects to read it here:
    > /oodt/projects/default/components/wmgr
    >
    > Which seems like a mismatch, no?
    >
    > Can you help resolve this? I’m trying to get AvroRPC and ZK-config,
    > merged, and
    > working in development branch, so that we can release a stable OODT 2.0.
    >
    > Cheers,
    > Chris
    >
    >
    >
    >
    



Mime
View raw message