oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mattmann, Chris A (3980)" <chris.a.mattm...@jpl.nasa.gov>
Subject Re: Anyone else seeing random build errors with 0.12?
Date Sat, 20 Feb 2016 15:05:32 GMT
yeah oddly it went away, so I’m good :)

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Chris Mattmann, Ph.D.
Chief Architect
Instrument Software and Science Data Systems Section (398)
NASA Jet Propulsion Laboratory Pasadena, CA 91109 USA
Office: 168-519, Mailstop: 168-527
Email: chris.a.mattmann@nasa.gov
WWW:  http://sunset.usc.edu/~mattmann/
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Adjunct Associate Professor, Computer Science Department
University of Southern California, Los Angeles, CA 90089 USA
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++





-----Original Message-----
From: Tom Barber <tom.barber@meteorite.bi>
Reply-To: "dev@oodt.apache.org" <dev@oodt.apache.org>
Date: Saturday, February 20, 2016 at 2:12 AM
To: "dev@oodt.apache.org" <dev@oodt.apache.org>
Subject: Re: Anyone else seeing random build errors with 0.12?

>I've not seen it, although I never fully trust local machine tests since
>day 1 when they didnt work in GMT. I have a clean LXC container to check
>it
>in and it's been testing okay and on jenkins which is pretty much my remit
>for a pass.
>On 20 Feb 2016 7:33 am, "Chris Mattmann" <chris.mattmann@gmail.com> wrote:
>
>> Hey Lewis - from a 0.12 clone. It built fine when I did
>> my release VOTE, then rebuilt and test on another machine
>> and crapped out.
>>
>> Tried again, working now. Odd.
>>
>> Cheers,
>> chris
>>
>> —
>> Chris Mattmann
>> chris.mattmann@gmail.com
>>
>>
>>
>>
>>
>>
>> -----Original Message-----
>> From: Lewis John Mcgibbney <lewis.mcgibbney@gmail.com>
>> Reply-To: <dev@oodt.apache.org>
>> Date: Friday, February 19, 2016 at 11:27 PM
>> To: "dev@oodt.apache.org" <dev@oodt.apache.org>
>> Subject: Re: Anyone else seeing random build errors with 0.12?
>>
>> >From master or 0.12 release Chris?
>> >
>> >On Fri, Feb 19, 2016 at 11:21 PM, Mattmann, Chris A (3980) <
>> >chris.a.mattmann@jpl.nasa.gov> wrote:
>> >
>> >> Hey Tom and team,
>> >>
>> >> On a fresh install of 0.12 on a new machine I’m seeing:
>> >>
>> >>
>> >> Failed tests:
>> >>   
>>TestMappedDataSourceCatalog>TestDataSourceCatalog.testAddMetadata:371
>> >> User not found: SA
>> >>
>> >>
>> 
>>>>TestMappedDataSourceCatalog>TestDataSourceCatalog.testAddProductReferen
>>>>ce
>> >>s:
>> >> 422 User not found: SA
>> >>
>> 
>>>>TestMappedDataSourceCatalog>TestDataSourceCatalog.testRemoveProduct:199
>> >> User not found: SA
>> >>
>> >>
>> 
>>>>TestMappedDataSourceCatalog>TestDataSourceCatalog.testFirstProductOnlyO
>>>>nF
>> >>ir
>> >> stPage:280 User not found: SA
>> >>
>> 
>>>>TestMappedDataSourceCatalog>TestDataSourceCatalog.testModifyProduct:237
>> >> User not found: SA
>> >>   
>>TestMappedDataSourceCatalog>TestDataSourceCatalog.testAddProduct:329
>> >> User not found: SA
>> >>
>> 
>>>>TestMappedDataSourceCatalog>TestDataSourceCatalog.testPassDatasource:53
>>>>0
>> >> User not found: SA
>> >>
>> 
>>>>TestMappedDataSourceCatalog>TestDataSourceCatalog.testRemoveMetadata:40
>>>>2
>> >> User not found: SA
>> >>   TestOrderedDataSourceCatalog.testOrdering:86 User not found: SA
>> >>   
>>TestOrderedDataSourceCatalog>TestDataSourceCatalog.testAddMetadata:371
>> >> User not found: SA
>> >>
>> >>
>> 
>>>>TestOrderedDataSourceCatalog>TestDataSourceCatalog.testAddProductRefere
>>>>nc
>> >>es
>> >> :422 User not found: SA
>> >>
>> 
>>>>TestOrderedDataSourceCatalog>TestDataSourceCatalog.testRemoveProduct:19
>>>>9
>> >> User not found: SA
>> >>
>> >>
>> 
>>>>TestOrderedDataSourceCatalog>TestDataSourceCatalog.testFirstProductOnly
>>>>On
>> >>Fi
>> >> rstPage:280 User not found: SA
>> >>
>> 
>>>>TestOrderedDataSourceCatalog>TestDataSourceCatalog.testModifyProduct:23
>>>>7
>> >> User not found: SA
>> >>   
>>TestOrderedDataSourceCatalog>TestDataSourceCatalog.testAddProduct:329
>> >> User not found: SA
>> >>
>> >>
>> 
>>>>TestOrderedDataSourceCatalog>TestDataSourceCatalog.testPassDatasource:5
>>>>30
>> >> User not found: SA
>> >>
>> >>
>> 
>>>>TestOrderedDataSourceCatalog>TestDataSourceCatalog.testRemoveMetadata:4
>>>>02
>> >> User not found: SA
>> >>   TestTypeHandler.testQuery:197 java.lang.Exception:
>> >> org.apache.oodt.cas.filemgr.structs.exceptions.CatalogException:
>>Error
>> >> ingesting product
>> >>[org.apache.oodt.cas.filemgr.structs.Product@38e4bead] :
>> >> User not found: SA
>> >>   TestTypeHandler.testAddAndGetMetadata:165 java.lang.Exception:
>> >> org.apache.oodt.cas.filemgr.structs.exceptions.CatalogException:
>>Error
>> >> ingesting product
>> >>[org.apache.oodt.cas.filemgr.structs.Product@17e1ac80] :
>> >> User not found: SA
>> >>
>> >> Tests in error:
>> >>   TestMappedDataSourceCatalog>TestDataSourceCatalog.testQuery:472 »
>> >> Catalog User...
>> >>   TestOrderedDataSourceCatalog>TestDataSourceCatalog.testQuery:472 »
>> >> Catalog Use...
>> >>
>> >> Tests run: 213, Failures: 19, Errors: 2, Skipped: 0
>> >>
>> >>
>> >> Any idea?
>> >>
>> >> Cheers,
>> >> Chris
>> >>
>> >> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>> >> Chris Mattmann, Ph.D.
>> >> Chief Architect
>> >> Instrument Software and Science Data Systems Section (398)
>> >> NASA Jet Propulsion Laboratory Pasadena, CA 91109 USA
>> >> Office: 168-519, Mailstop: 168-527
>> >> Email: chris.a.mattmann@nasa.gov
>> >> WWW:  http://sunset.usc.edu/~mattmann/
>> >> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>> >> Adjunct Associate Professor, Computer Science Department
>> >> University of Southern California, Los Angeles, CA 90089 USA
>> >> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>> >>
>> >>
>> >>
>> >>
>> >
>> >
>> >--
>> >*Lewis*
>>
>>
>>

Mime
View raw message