oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lewis John Mcgibbney <lewis.mcgibb...@gmail.com>
Subject Re: how to run OPSUI from scratch
Date Tue, 01 Sep 2015 18:57:32 GMT
Hi Val,
Which version of the software are you using?
Can you try reinstalling allows

Mvn clean install -X

The above is debug mode and will give you more verbose output.
Thanks

On Tuesday, September 1, 2015, Mallder, Valerie <Valerie.Mallder@jhuapl.edu>
wrote:

> Hi All,
>
> I've gotten workflow manager, file manager running (without resource
> manager) and now I'd like to figure out how run the OPSUI. When I was using
> the Radix install, this was pretty easy. But now I'm starting from scratch
> and trying to following the instructions on the wiki.  I am using the
> instructions called "Quick Start for PCS OPSUI".
>
> I watched the video, but Chris is talking a bit too fast and the screen is
> unreadable so I can't see the exact commands he is entering on the command
> line that are related to OPSUI.
>
> At the bottom of the page there are two options "Building from src" and
> "Using the WAR directly from the central repository".  I chose "Building
> from src".
>
> And when I do number 2 "mvn install tomcat:run-war" I get the following
> errors:  What should I do?
>
> Thanks,
> Val
>
>
> [INFO] Scanning for projects...
> Downloading:
> http://repo.maven.apache.org/maven2/install/tomcat/maven-metadata.xml
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 1.136s
> [INFO] Finished at: Tue Sep 01 13:34:03 GMT-05:00 2015
> [INFO] Final Memory: 20M/1448M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Error resolving version for plugin 'install:tomcat' from the
> repositories [local (/homes/malldva1/.m2/repository), central (
> http://repo.maven.apache.org/maven2)]: Plugin not found in any plugin
> repository -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/PluginVersionResolutionException
>
>
>
>
> Valerie A. Mallder
>
> New Horizons Deputy Mission System Engineer
> The Johns Hopkins University/Applied Physics Laboratory
> 11100 Johns Hopkins Rd (MS 23-282), Laurel, MD 20723
> 240-228-7846 (Office) 410-504-2233 (Blackberry)
>
>

-- 
*Lewis*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message