oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lewis John Mcgibbney <lewis.mcgibb...@gmail.com>
Subject Re: radix install cas-workflow-0.3.jar vs.cas-workflow-0.7.jar
Date Sat, 11 Oct 2014 02:28:05 GMT
Hi Valerie,

On Fri, Oct 10, 2014 at 3:30 PM, Mallder, Valerie <
Valerie.Mallder@jhuapl.edu> wrote:

>
>
> I used the radix installation script to install oodt on my system. I
> modified it to to pull version 7 rather than version 6, and my project name
> is jedi.
>

OK, so what version of other OODT module are you using? I am assuming 0.6
with the exception of push-pull? Can you please clarify?
Can you also specify how you invoked the script? Do you mean the Maven
pom.xml?


> Here are listings of all the files in my project directory (jedi-oodt)
> and my deployment (oodt-deploy) directory.
>
>
>
> Please note that I had to copy oodt-deploy/cas-filemgr-0.7.jar to oodt-deploy
> /workflow/lib in order to get past the CoreMetKeys class not found
> exception that occurred when I tried to start my pge crawler task via the
> workflow manager (which still doesn’t start up, but for different reasons
> which I will post separately)
>

Hopefully once you follow Chris' suggestions on the other thread you can
upgrade to 0.7 anyway. Please let us know how this goes on.


>
>
> I noticed that oodt-deploy/resmgr/lib contained, cas-workflow-0.3.jar,
> but oodt-deploy/pge/lib, oodt-deploy/workflow/lib, oodt-deploy/crawler/lib,
> and oodt-deploy/filemgr/lib contain cas-workflow-0.7.jar. So I copied v0.7
> to resmgr/lib and I am running with that now.
>

I have looked into the 0.6 and 0.7 tag releases and cannot pin point any
obvious bugs within the Maven pom.xml configurations. I am pretty stumped
on how in gods name this got here!
https://svn.apache.org/repos/asf/oodt/tags/


>
>
> I also noticed that oodt-deploy/pge/lib, oodt-deploy/resmgr/lib, and oodt-deploy/workflow/lib
> contain cas-pge-0.3.jar. Is this the correct version?
>

I really don't think so. I understand that some people still use 0.3,
however I am positive that this should not be happening if you are running
0.6 or 0.7.


> Shouldn’t it be version 0.7?
>

Yes it certainly should be!


> I am noticing that some of the runtime exceptions that I have received
> actually occur on line numbers in pge that do not match up to actual
> lines of code. So, I am thinking that I might have the wrong version of
> cas pge installed.
>

Yes I am smelling the same fishy smell as you here! If you can answer the
intial question of which version you started working with then maybe we can
get to the bottom of this. If you are able to as well, I would try flushing
out the local ~/.m2/ cache. Maven sometimes has a mind of its own,
especially if you have been developing a lot and not flushed it for a while.


>
>
> I did pull a copy of the full oodt-0.7 from the repository into a
> different directory so that I could have a copy here locally for
> referencing the code. But I hadn’t actually built the whole thing yet. Is
> it still correct to simply execute “mvn package”?
>

Yes, I would however also follow Tyler suggestions, and also invoke the
-skipTests flag
e.g. mvn clean install -DskipTests


> I hope so because that’s what I did. I just wanted to check to see if
> cas-pge-0.7.jar gets created rather than cas-pge-0.3.jar. But the build
> didn’t finish because maven is telling me I have an OutOfMemoryError
> right in the middle of compiling the cas-pge!.  Oh joy.
>

Happy Fridays.


> So I had to build it in parts and I attached the output files. And yes,
> cas-pge-0.7.jar does get created, so I copied that to my oodt-deploy
> directory and I’m running with that now as well.
>
>
>
> ACK, please see above and we can scope further. This is pretty painful
sounding!!!
Lewis

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message