oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ramirez, Paul M (398J)" <paul.m.rami...@jpl.nasa.gov>
Subject Re: radix install cas-workflow-0.3.jar vs.cas-workflow-0.7.jar
Date Sat, 11 Oct 2014 03:58:35 GMT
Hi Valerie,

The cas-pge at 0.3 was on purpose as there was a bug in OODT 0.6 that required is to push
it back to 0.3. I believe that big is resolved I 0.7 and we should put that dependency back
at 0.7. This is actually set in the main pom file before you build your RADiX install of OODT.

The cas-workflow being 0.7 is a big and should be changed. Can you create a Jira issue and
assign it to me and I will fix it this weekend.

May I also say that you are awesome for you extensive testing and troubleshooting.

Thanks,
Paul

Sent from my iPhone

On Oct 10, 2014, at 3:31 PM, Mallder, Valerie <Valerie.Mallder@jhuapl.edu<mailto:Valerie.Mallder@jhuapl.edu>>
wrote:

Hi Lewis,

I used the radix installation script to install oodt on my system. I modified it to to pull
version 7 rather than version 6, and my project name is jedi. Here are listings of all the
files in my project directory (jedi-oodt) and my deployment (oodt-deploy) directory.

Please note that I had to copy oodt-deploy/cas-filemgr-0.7.jar to oodt-deploy /workflow/lib
in order to get past the CoreMetKeys class not found exception that occurred when I tried
to start my pge crawler task via the workflow manager (which still doesn’t start up, but
for different reasons which I will post separately)

I noticed that oodt-deploy/resmgr/lib contained, cas-workflow-0.3.jar, but oodt-deploy/pge/lib,
oodt-deploy/workflow/lib, oodt-deploy/crawler/lib, and oodt-deploy/filemgr/lib contain cas-workflow-0.7.jar.
So I copied v0.7 to resmgr/lib and I am running with that now.

I also noticed that oodt-deploy/pge/lib, oodt-deploy/resmgr/lib, and oodt-deploy/workflow/lib
contain cas-pge-0.3.jar. Is this the correct version? Shouldn’t it be version 0.7?  I am
noticing that some of the runtime exceptions that I have received actually occur on line numbers
in pge that do not match up to actual lines of code. So, I am thinking that I might have the
wrong version of cas pge installed.

I did pull a copy of the full oodt-0.7 from the repository into a different directory so that
I could have a copy here locally for referencing the code. But I hadn’t actually built the
whole thing yet. Is it still correct to simply execute “mvn package”? I hope so because
that’s what I did. I just wanted to check to see if cas-pge-0.7.jar gets created rather
than cas-pge-0.3.jar. But the build didn’t finish because maven is telling me I have an
OutOfMemoryError right in the middle of compiling the cas-pge!.  Oh joy.  So I had to build
it in parts and I attached the output files. And yes, cas-pge-0.7.jar does get created, so
I copied that to my oodt-deploy directory and I’m running with that now as well.

Thanks!
Valerie



Valerie A. Mallder

New Horizons Deputy Mission System Engineer
The Johns Hopkins University/Applied Physics Laboratory
11100 Johns Hopkins Rd (MS 23-282), Laurel, MD 20723
240-228-7846 (Office) 410-504-2233 (Blackberry)

<filelist_and_build_log.zip>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message