oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From YunHee Kang <yunh.k...@gmail.com>
Subject Re: Trouble when installing "PushPull protocol plugins"
Date Tue, 24 Jul 2012 15:08:43 GMT
Hi Chris,

Your guideline solved this problem.

>     <activeProfiles>
>       <profile>oodt</profile>
>     </activeProfiles>
>> </settings>

After I changed  the name of element <profile> into  <activeProfile>,
eventually I got  "oodt-pushpull-plugins-core-0.4.jar".


 [INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] ------------------------------------------------------------------------
[INFO] Apache CAS PushPull Plugins Dependency Fixer .......... SUCCESS [6.086s]
[INFO] CAS Push-Pull-Framework Plugins Core Libs ............. SUCCESS [13.575s]
[INFO] Apache OODT CAS PushPull Plugins ...................... SUCCESS [0.004s]
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 19 seconds
[INFO] Finished at: Tue Jul 24 23:44:02 KST 2012
[INFO] Final Memory: 40M/292M
[INFO] ------------------------------------------------------------------------


Thanks,
Yunhee

2012/7/24 Mattmann, Chris A (388J) <chris.a.mattmann@jpl.nasa.gov>:
> Hi YunHee,
>
> Try something like this:
>
> On Jul 24, 2012, at 1:31 AM, YunHee Kang wrote:
>
>> Hi Chris,
>>
>>> I think you need to active the profile below: do you see something
>>> on mvn when you run it that it searches http://oodt.jpl.nasa.gov for
>>> ftp4che?
>>>
>> I wrote a file settings.xml as  follows:
>> <settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
>>  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
>>                      http://maven.apache.org/xsd/settings-1.0.0.xsd">
>>  <localRepository/>
>>  <interactiveMode/>
>>  <usePluginRegistry/>
>>  <offline/>
>>  <pluginGroups/>
>>  <servers/>
>>  <mirrors/>
>>  <proxies/>
>>  <profiles>
>>    <profile>
>   Here add: <id>oodt</id>
>
>>     <repositories>
>>       <repository>
>>        <id>oodt-m2-repo</id>
>>        <name>OODT Maven2 Repository</name>
>>        <url>http://oodt.jpl.nasa.gov/download/private</url>
>>        <releases>
>>         <enabled>true</enabled>
>>        </releases>
>>        <snapshots>
>>         <enabled>true</enabled>
>>        </snapshots>
>>       </repository>
>>      </repositories>
>>    </profile>
>>  </profiles>
>>  <activeProfiles/>
>  Here change this to:
>     <activeProfiles>
>       <profile>oodt</profile>
>     </activeProfiles>
>> </settings>
>>
>> Let me know how to activate the profile.
>
> See above.
>
>>
>>> If not, your settings profile isn't active and you need to active it by
>>> giving it an id, and then typing mvn -Pid install
>>
>> When I ran the mvn command as follows, I got the same result  before.
> [..snip..]
>
> Now you don't need to pass -P since you have it active in your settings.xml
> by default (with the above mods).
>
> Cheers,
> Chris
>
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> Chris Mattmann, Ph.D.
> Senior Computer Scientist
> NASA Jet Propulsion Laboratory Pasadena, CA 91109 USA
> Office: 171-266B, Mailstop: 171-246
> Email: chris.a.mattmann@nasa.gov
> WWW:   http://sunset.usc.edu/~mattmann/
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> Adjunct Assistant Professor, Computer Science Department
> University of Southern California, Los Angeles, CA 90089 USA
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>

Mime
View raw message