oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ramirez, Paul M (388J)" <paul.m.rami...@jpl.nasa.gov>
Subject Re: Filemgr query not returning list of values
Date Tue, 13 Mar 2012 00:40:16 GMT
Hey Guys,

Just to let you know I believe the issue has been addressed in a fix that is currently under
review and I'll commit later tonight.

--Paul


On Mar 12, 2012, at 7:33 AM, Sheryl John wrote:

> Hi Tom,
> 
> Thanks for looking into this. I just commented about the options I was
> using in OODT-404 in reply to Brian's question.
> 
> 
> 
> 
> 
> On Mon, Mar 12, 2012 at 6:05 AM, Thomas Bennett <lmzxq.tom@gmail.com> wrote:
> 
>> Hey Paul,
>> 
>> Thanks for the reply.
>> 
>> What backend are you using for the catalog?
>> 
>> 
>> Lucene
>> 
>> 
>>> I just committed a unit test to show a round trip ingestion via the file
>>> manager client.
>> 
>> 
>> Thanks. I'll take a look at the test.
>> 
>> 
>>> This had multivalued metadata and stored and returned just fine. As Chris
>>> mentioned my next step is going to be to look into the new CLI stuff.
>>> 
>> 
>> Hmmm. Bazaar. I'll recheck what I've seen and get back to you with more
>> details ;)
>> 
>> Cheers,
>> Tom
>> 
>> 
>> 
>> 
>>> 
>>> --Paul
>>> 
>>> Sent from my iPhone
>>> 
>>> On Mar 12, 2012, at 1:28 AM, "Thomas Bennett" <lmzxq.tom@gmail.com>
>> wrote:
>>> 
>>>> Hi,
>>>> 
>>>> Sorry... I realise I forgot to add some more to this email before I
>> sent
>>> it
>>>> ;-)
>>>> 
>>>> From what I can see the problem is on the File Manager side. I've
>>> captured
>>>> the XML-RPC methodResponse to an ingestProduct methodCall and there
>>>> are defiantly only single values in the reply...
>>>> 
>>>> I'll dig a bit further and keep you guys posted.
>>>> 
>>>> Cheers,
>>>> Tom
>>>> 
>>>> On 12 March 2012 05:56, Mattmann, Chris A (388J) <
>>>> chris.a.mattmann@jpl.nasa.gov> wrote:
>>>> 
>>>>> Hey Tom,
>>>>> 
>>>>> OK, I'll take a look at this with Paul R. too...
>>>>> 
>>>>> Cheers,
>>>>> Chris
>>>>> 
>>>>> On Mar 9, 2012, at 9:16 PM, Thomas Bennett wrote:
>>>>> 
>>>>>> Hey Sheryl,
>>>>>> 
>>>>>> Just to let you know that I've also experienced exactly the same
>>> problem.
>>>>>> 
>>>>>> Cheers,
>>>>>> Tom
>>>>>> 
>>>>>> Sent from my iPhone
>>>>>> 
>>>>>> On 10 Mar 2012, at 1:37 AM, Sheryl John <sheryljj@gmail.com>
wrote:
>>>>>> 
>>>>>>> Hi,
>>>>>>> 
>>>>>>> I'm working with 0.4-SNAPSHOT( not latest build) and when querying
>> the
>>>>>>> Filemanager on a multivalue key, it's not returning the expected
>> list
>>> of
>>>>>>> values but it returned only the first value. I tested the query
on
>> the
>>>>>>> filemgr-client and the query-tool and both returns only the first
>>> value.
>>>>>>> 
>>>>>>> I checked the filemgr catalog using the lucene luke tool and
I can
>> see
>>>>> all
>>>>>>> the expected values for that key, so the key does have more than
one
>>>>>>> metadata value. I tried the same query on 0.3v and that returns
the
>>>>>>> concatenated list of values for the key.
>>>>>>> 
>>>>>>> Have I missed out something or did anyone else come across this
>> before
>>>>> with
>>>>>>> the 0.4-SNAPSHOT? I didn't check the code yet..
>>>>>>> 
>>>>>>> Thanks
>>>>>>> Sheryl
>>>>> 
>>>>> 
>>>>> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>>>>> Chris Mattmann, Ph.D.
>>>>> Senior Computer Scientist
>>>>> NASA Jet Propulsion Laboratory Pasadena, CA 91109 USA
>>>>> Office: 171-266B, Mailstop: 171-246
>>>>> Email: chris.a.mattmann@nasa.gov
>>>>> WWW:   http://sunset.usc.edu/~mattmann/
>>>>> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>>>>> Adjunct Assistant Professor, Computer Science Department
>>>>> University of Southern California, Los Angeles, CA 90089 USA
>>>>> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>>>>> 
>>>>> 
>>> 
>> 
> 
> 
> 
> -- 
> -Sheryl


Mime
View raw message