oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Verma, Rishi (388J)" <Rishi.Ve...@jpl.nasa.gov>
Subject Re: Shutting down CAS PGE workflow instances
Date Thu, 13 Oct 2011 00:32:09 GMT
Hi Shreyl,

Thanks for the confirmation!

I am using 0.4-SNAPSHOT.

I just checked and 0.3-SNAPSHOT is able to stop workflows via WorkflowInst ID just fine.

Something new in the latest build must have broke.. will look into it and file an issue if
I find some problem in the code.

thanks -
rishi

On Oct 12, 2011, at 5:14 PM, Sheryl John wrote:

Which version of the Workflow Manager are you working on?

Try the 0.3-SNAPSHOT version if you working on one of the latest versions of the trunk. I'm
not sure if this will fix this.

On Wed, Oct 12, 2011 at 5:04 PM, Sheryl John <sheryljj@gmail.com<mailto:sheryljj@gmail.com>>
wrote:
Hi Rishi,

Yes, you are using the command-line argument correctly. I just tried stopping some instances
( their statuses were FINISHED) and it works for me.

I tried :
./wmgr-client --url http://localhost:9001<http://localhost:9001/> --operation --stopWorkflowInst
--id a2741f59-e631-11e0-ab26-03f35922ef75


The messages:

WARNING: WorkflowEngine: Attempt to stop workflow instance id: a2741f59-e631-11e0-ab26-03f35922ef75,
however, this engine is not tracking its execution
Oct 12, 2011 4:49:34 PM sun.net.www.protocol.http.HttpURLConnection getInputStream
FINE: sun.net.www.MessageHeader@6aa6aeed5 pairs: {null: HTTP/1.1 200 OK}{Server: Apache XML-RPC
1.0}{Connection: close}{Content-Type: text/xml}{Content-Length: 121}
Successfully stopped workflow: [a2741f59-e631-11e0-ab26-03f35922ef75]


So, I'm not sure whats causing your NullPointerException.

On Wed, Oct 12, 2011 at 4:41 PM, Verma, Rishi (388J) <Rishi.Verma@jpl.nasa.gov<mailto:Rishi.Verma@jpl.nasa.gov>>
wrote:
Hi all -

I'm trying to stop one of my PGE workflows using the wmgr-client tool and the "--stopWorkflowinst"
argument.

I'm repeatedly getting a NullPointerException after trying to stop a running workflow.

I believe I am using the '--stopWorkflowInst' argument correctly. Has anyone had luck with
shutting down workflow PGE instances using this method?

Thanks!
rishi

-----
$ ./wmgr-client --url http://localhost:9001<http://localhost:9001/> --operation --getWorkflowInsts
...
Instance: [id=ed798a3d-f075-11e0-bc2c-21311056edb2, status=CRAWLING, currentTask=urn:oodt:ProteomeLinux,
workflow=ProteomeLinuxWorkflow,wallClockTime=8524.3347,currentTaskWallClockTime=3.2414]
...

$ ./wmgr-client --url http://localhost:9001<http://localhost:9001/> --operation --stopWorkflowInst
--id ed798a3d-f075-11e0-bc2c-21311056edb2
org.apache.xmlrpc.XmlRpcException: java.lang.Exception: java.lang.NullPointerException
       at org.apache.xmlrpc.XmlRpcClientResponseProcessor.decodeException(XmlRpcClientResponseProcessor.java:104)
       at org.apache.xmlrpc.XmlRpcClientResponseProcessor.decodeResponse(XmlRpcClientResponseProcessor.java:71)
       at org.apache.xmlrpc.XmlRpcClientWorker.execute(XmlRpcClientWorker.java:73)
       at org.apache.xmlrpc.XmlRpcClient.execute(XmlRpcClient.java:194)
       at org.apache.xmlrpc.XmlRpcClient.execute(XmlRpcClient.java:185)
       at org.apache.xmlrpc.XmlRpcClient.execute(XmlRpcClient.java:178)
       at org.apache.oodt.cas.workflow.system.XmlRpcWorkflowManagerClient.stopWorkflowInstance(XmlRpcWorkflowManagerClient.java:341)
       at org.apache.oodt.cas.workflow.system.XmlRpcWorkflowManagerClient.main(XmlRpcWorkflowManagerClient.java:907)
Exception in thread "main" java.lang.RuntimeException: java.lang.Exception: java.lang.NullPointerException
       at org.apache.oodt.cas.workflow.system.XmlRpcWorkflowManagerClient.main(XmlRpcWorkflowManagerClient.java:913)




--
-Sheryl



--
-Sheryl


Mime
View raw message