oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From keran zhou <zhouke...@gmail.com>
Subject Eclipse is running in a JRE, but a JDK is required
Date Tue, 22 Mar 2011 01:20:25 GMT
Hi,

I've installed the m2eclipse, but when i start my eclipse, it always shows that
"Eclipse is running in a JRE, but a JDK is required
  Some Maven plugins may not work when importing projects or updating
source folders."

Hence I cannot compile the OODT.

would you please tell me how to deal with it?

my eclipse.ini is as following:

-startup
plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.2.R36x_v20101222
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx384m


Thank you very much!

Keran

Mime
View raw message