oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mattmann, Chris A (388J)" <chris.a.mattm...@jpl.nasa.gov>
Subject Re: unable to build OODT
Date Thu, 17 Mar 2011 04:17:44 GMT
Hi Andy,

> I tried building with Maven 2.2.1 per your suggestion but was running into
> different issues entirely.

Interesting. Care to share any of them?

> 
> I decided to switch gears and start building on my Mac (which apparently had
> Maven 2.2.1 installed by default).  After a couple hours of build errors I
> tracked the issue down to about 20 source files whose names ended with
> "0000644" for some odd reason.  I tried downloading the OODT source again
> from another computer and confirmed the oddly-named files.

Whoah that's weird! Were they intermediate unit test files? I couldn't confirm their presence
in the release tarball and the bits up on http://www.apache.org/dyn/closer.cgi/oodt:

1. wget "http://www.fightrice.com/mirrors/apache//oodt/apache-oodt-0.2-src.tar.gz"
2. tar xvzf *.tar.gz
3. cd apache-oodt-0.2-src
4.  find ./ -type f | grep 644

> 
> I identified all of the weird files with "find ./ -type f | grep 644" from
> the root OODT directory and renamed them all, removing the "0000644".  After
> doing so my build and install were successful.

Glad you got it built in the end! Weird about those files -- I wonder if they were temporary
files left by Maven during a prior failed build?

Cheers,
Chris

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Chris Mattmann, Ph.D.
Senior Computer Scientist
NASA Jet Propulsion Laboratory Pasadena, CA 91109 USA
Office: 171-266B, Mailstop: 171-246
Email: chris.a.mattmann@nasa.gov
WWW:   http://sunset.usc.edu/~mattmann/
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Adjunct Assistant Professor, Computer Science Department
University of Southern California, Los Angeles, CA 90089 USA
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


Mime
View raw message