oodt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mattmann, Chris A (388J)" <chris.a.mattm...@jpl.nasa.gov>
Subject Re: tika 0.8-SNAPSHOT ERROR
Date Wed, 12 Jan 2011 04:02:56 GMT
Hey Camaroon,

This is an issue with the 0.1-incubating release, where the Tika-0.8-SNAPSHOT is not available
in the default Maven Central external repos anymore, so if you never got it, the build yells
at you.

0.2 (the current trunk version) contains a patch where this is fixed, OODT-59 [1], that Dave
Kale fixed. Brian Foster and  I have been taking care of some other Tika issues (e.g., upgrading
to the latest version across all the components, which I mentioned to Adam Estrada on the
dev@ list the other day [2]).

HTH!

Cheers,
Chris

[1] https://issues.apache.org/jira/browse/OODT-59
[2] http://s.apache.org/dTh

On Jan 11, 2011, at 1:56 PM, Cameron Goodale wrote:

> Guys,
> 
> I attempted to mvn install oodt to use workflow on a project and I was
> greeted with the following error.
> 
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
> 
> Missing:
> ----------
> 1) org.apache.tika:tika-core:jar:0.8-SNAPSHOT
> 
>  Try downloading the file manually from the project website.
> 
>  Then, install it using the command:
>      mvn install:install-file -DgroupId=org.apache.tika
> -DartifactId=tika-core -Dversion=0.8-SNAPSHOT -Dpackaging=jar
> -Dfile=/path/to/file
> 
>  Alternatively, if you host your own repository you can deploy the file
> there:
>      mvn deploy:deploy-file -DgroupId=org.apache.tika
> -DartifactId=tika-core -Dversion=0.8-SNAPSHOT -Dpackaging=jar
> -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
> 
>  Path to dependency:
>   1) org.apache.oodt:pushpull:jar:0.1-incubating
>   2) org.apache.tika:tika-core:jar:0.8-SNAPSHOT
> 
> ----------
> 1 required artifact is missing
> 
> 
> Is this some maven issue?  Or something I should log a JIRA issue for?  Any
> help would be awesome.
> 
> 
> 
> Cameron
> 
> 
> -- 
> 
> Sent from a Tin Can attached to a String


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Chris Mattmann, Ph.D.
Senior Computer Scientist
NASA Jet Propulsion Laboratory Pasadena, CA 91109 USA
Office: 171-266B, Mailstop: 171-246
Email: chris.a.mattmann@nasa.gov
WWW:   http://sunset.usc.edu/~mattmann/
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Adjunct Assistant Professor, Computer Science Department
University of Southern California, Los Angeles, CA 90089 USA
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


Mime
View raw message