oodt-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris A. Mattmann (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (OODT-727) Rename actions to their prior names in CAS-Crawler
Date Sat, 15 Jul 2017 04:08:00 GMT

     [ https://issues.apache.org/jira/browse/OODT-727?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris A. Mattmann resolved OODT-727.
------------------------------------
    Resolution: Won't Fix

Meh - guess wasn't worth changing them - use this as updated doc for that.

> Rename actions to their prior names in CAS-Crawler
> --------------------------------------------------
>
>                 Key: OODT-727
>                 URL: https://issues.apache.org/jira/browse/OODT-727
>             Project: OODT
>          Issue Type: Bug
>          Components: crawler
>            Reporter: Chris A. Mattmann
>            Assignee: Chris A. Mattmann
>             Fix For: 1.1
>
>
> OODT-325 and this commit http://svn.apache.org/viewvc?view=revision&revision=1294389
introduced new names to CrawlerActionBeans, such as
> * Renaming UpdateWorkflowStatusToIngest to TriggerPostIngestWorkflow
> * Renaming MoveMetadataToBackupDir to MoveMetadataFileToBackupDir
> * Renaming MoveMetadataToFailureDir to MoveMetadataFileToFailureDir
> You can see all the differences by running this command:
> {noformat}
> curl "http://svn.apache.org/viewvc/oodt/trunk/crawler/src/main/resources/action-beans.xml?r1=1294389&r2=1294388&pathrev=1294389&view=patch"
| grep id | cut -d\" -f2 | cut -d\+ -f2 | grep -v \ | sort<{noformat}
> Which amount to:
> {noformat}
> CheckMetFileExists
> CheckMetFileExists
> DeleteDataFile
> DeleteDataFile
> DeleteMetadataFile
> DeleteMetadataFile
> DeletePushpullMetFile
> DeletePushpullMetFile
> IngestAncillaryFile
> IngestAncillaryFile
> MoveDataFileToFailureDir
> MoveDataFileToFailureDir
> MoveMetadataFileToBackupDir
> MoveMetadataFileToFailureDir
> MoveMetadataToBackupDir
> MoveMetadataToFailureDir
> MovePushpullMetFileToBackupDir
> MovePushpullMetFileToBackupDir
> MovePushpullMetFileToFailureDir
> MovePushpullMetFileToFailureDir
> SendNotification
> SendNotification
> TriggerPostIngestWorkflow
> Unique
> Unique
> UpdateWorkflowStatusToIngest
> ignoreInvalidAddresses
> ignoreInvalidAddresses
> {noformat}
> I can find no justification for these changes and technically it broke back compatibility
with folks using those action names. I am going to change the action names back to what they
were called.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message