oodt-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris A. Mattmann (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (OODT-190) WorkflowCondition configuration isn't read
Date Wed, 04 May 2011 21:15:03 GMT

     [ https://issues.apache.org/jira/browse/OODT-190?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris A. Mattmann resolved OODT-190.
------------------------------------

    Resolution: Fixed

In r1099608, I fixed this issue, and also did a bit of refactoring:
 - deprecated a wonky method (#getTaskConfig in WorkflowCondition?) and added a #getCondConfig
method.
 - cleaned up the constructor to create objects by default

> WorkflowCondition configuration isn't read
> ------------------------------------------
>
>                 Key: OODT-190
>                 URL: https://issues.apache.org/jira/browse/OODT-190
>             Project: OODT
>          Issue Type: Bug
>          Components: workflow manager
>    Affects Versions: 0.1-incubating, 0.2
>         Environment: while working on OODT-189 and on OODT-156
>            Reporter: Chris A. Mattmann
>            Assignee: Chris A. Mattmann
>            Priority: Blocker
>              Labels: condition, configuratoin, serde, workflow
>             Fix For: 0.3
>
>
> While working on OODT-189 and OODT-156 I noticed this blocker bug. XmlRpcStructFactory
doesn't SerDe WorkflowConditionConfigurations, since it seems they were bolted on at some
point. This needs to be fixed before 0.3 ships.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message