oltu-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jasha Joachimsthal <ja...@apache.org>
Subject Upgrade to Java 8
Date Fri, 27 Oct 2017 08:51:23 GMT
Hi all,

Apache Oltu is currently compiled to run on Java 6. This Java version is
EOL since December 2015 [1]. Java 8 has been released in March 2014,
more than 3,5 years ago.

We're facing an issue where we cannot change to a JSON library that has
a compatible license for Apache projects, because the version we need is
not supported in Java 6. [2]

Are there any objections to drop support for Java 6 in Apache Oltu and
set the minimal JDK version to 1.8?

[1] http://www.oracle.com/technetwork/java/eol-135779.html
[2] https://issues.apache.org/jira/browse/OLTU-209

Regards,

Jasha



Mime
View raw message