oltu-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simone Tripodi <simone.trip...@gmail.com>
Subject [VOTE] Which Java version?
Date Tue, 22 Jun 2010 18:12:39 GMT
Hi all,
Pid and I are doing - even if small - progresses to design the OAuth
java APIs, there are small but crucial points that have to be fixed.
We need now to know which Java version we should support, so please
cast your votes to

[] Java6
[] Java5

Choices explanations would be more than appreciated.

My vote is for Java6, mainly because we can use:

* the ServiceLoader engine;
* the APT invoked by javac (and we could generate oauth POJOs
marshallers/unmarshallers to/from various formats);
* the built-in JAXB APIs.

All the best,
Simo

http://people.apache.org/~simonetripodi/
http://www.99soft.org/

Mime
View raw message