oltu-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid <...@pidster.com>
Subject Multiple implementations, different versions
Date Mon, 21 Jun 2010 08:57:53 GMT

In the case where a user/consumer/client is integrating with multiple
different Providers who are not all implementing the same version of
OAuth, we would need to ensure implementations of each version are able
to co-exist.

This is partially addressed by passing a version into the initial static
method on o.a.amber.OAuth, but we'd also need to ensure that
implementations are in compatible but parallel sub-packages.

Say:

 o.a.amber.implv10...
 o.a.amber.implv20...


Thoughts/problems?


p



Mime
View raw message