olingo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Günter (JIRA) <j...@apache.org>
Subject [jira] [Closed] (OLINGO-1311) Can not get entity with string key containing "_"
Date Tue, 23 Oct 2018 09:15:00 GMT

     [ https://issues.apache.org/jira/browse/OLINGO-1311?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Matthias Günter closed OLINGO-1311.
-----------------------------------
       Resolution: Implemented
    Fix Version/s: V2 2.0.11

Sorry for the ticket. I have updated V2.0.11 to latest version (last commit [https://github.com/apache/olingo-odata2/commit/d32a900a45e77ae41eeb6962755cda0e6452d3be)] and
all is working now as expected.

> Can not get entity with string key containing "_"
> -------------------------------------------------
>
>                 Key: OLINGO-1311
>                 URL: https://issues.apache.org/jira/browse/OLINGO-1311
>             Project: Olingo
>          Issue Type: Bug
>          Components: odata2-jpa
>    Affects Versions: V2 2.0.11
>            Reporter: Matthias Günter
>            Priority: Major
>             Fix For: V2 2.0.11
>
>
> This issue is similar to OLINGO-1098 and OLINGO-1218. Currently it is not possible to
get an entity by a string key which contains an underscore "_".
> I have tested the mentioned above tickets and they are working now as expected:
> {code:java}
> Cars?$filter=Id eq 'Model_3'
> {code}
> But when trying to get the data for that single entry I do not get the correct response
(empty response):
> {code:java}
> Cars('Model_3'){code}
> I had a look at the previous commits but unfortunely I am not that deep in Olingo Core
coding to solve the issue myself so I can create a PR.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message