ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Brohl <michael.br...@ecomify.de>
Subject Re: Installation trouble
Date Thu, 23 Jan 2020 12:07:34 GMT
Hi,

as you might have noticed, my answer was addressed to Parminder's 
answer, particularily the fact that the gradlew file is not included.

I may come back to your topics if noone else beats me to it.

Best regards,

Michael Brohl

ecomify GmbH - www.ecomify.de


Am 22.01.20 um 20:50 schrieb L:
> And this still does not help why my gradlew seems to do nothing.
>
> I've been through the README.md and I met all the requirements (not 
> many listed).
> What in the README did I miss?
>
> Excerpts from the README:
>
> The first requirement to run OFBiz is to have the Java Development Kit 
> (JDK)
> version 8 installed on your system (not just the JRE, but the full 
> JDK) which
> you can download from the below link.
>
>     [root@localhost ~]# java -version
>     openjdk version "11.0.6" 2020-01-14 LTS
>     OpenJDK Runtime Environment 18.9 (build 11.0.6+10-LTS)
>     OpenJDK 64-Bit Server VM 18.9 (build 11.0.6+10-LTS, mixed mode, 
> sharing)
>
> The second requirement is to setup the Gradle wrapper files that are used
> build the system.
> order to fulfill this requirement, you can run the following command:
>
> Unix-like OS:
> `./gradle/init-gradle-wrapper`
>
>     [root@localhost ~]# cd /usr/local/ofbiz/
>     [root@localhost ofbiz]# ./gradle/init-gradle-wrapper.sh
>      === Prepare operation ===
>     /usr/local/ofbiz/gradle/wrapper/gradle-wrapper.jar not found, we 
> download it
>      ===     Download gradle-wrapper.jar ===
>      === Download gradle-wrapper.properties ===
>      === Download script wrapper ===
>      === Control downloaded files ===
>     gradle/wrapper/gradle-wrapper.jar: OK
>     gradle/wrapper/gradle-wrapper.properties: OK
>     gradlew: OK
>
> So far, so good ( I think, it only took 3 seconds and no other 
> output).  Then:
>
> Quick start
> -----------
>
> To quickly install and fire-up OFBiz, please follow the below 
> instructions
> from the command line at the OFBiz top level directory (folder)
>
> ### Prepare OFBiz:
> Unix-like OS:
> `./gradlew cleanAll loadDefault`
>
>     [root@localhost ofbiz]# ./gradlew cleanAll loadDefault
>     [root@localhost ofbiz]#
>
> Unix-like OS:
> `./gradlew ofbiz`
>
>     [root@localhost ofbiz]# ./gradlew ofbiz
>     [root@localhost ofbiz]#
>
> Again no outout and appears to do NOTHING.
>
>
> On 1/22/20 12:42 PM, Michael Brohl wrote:
>> This is well documented in the README along with the system 
>> requirements which is always a good read ;-)
>>
>> You can find the reasons for this here: [1]
>>
>> Thanks,
>>
>> Michael Brohl
>>
>> ecomify GmbH - www.ecomify.de
>>
>>
>> [1] https://issues.apache.org/jira/browse/OFBIZ-10145
>>
>> Am 22.01.20 um 15:08 schrieb Parminder S. Lehal:
>>> The problem lies with the download files. Some of the zip files *even
>>> the latest 16.11 zip) does not have gradlew file included in them. It
>>> is pathetic that the final package file served  from the mirrors is
>>> incomplete(May be.... someone will pay some attention to this decline
>>> in quality). I also found this after wasting some time. Easier
>>> solution may be to use svn for downloading whatever version you are
>>> looking for.
>>> On Wed, 2020-01-22 at 10:32 +0100, Gil Portenseigne wrote:
>>>> On Wed, Jan 22, 2020 at 10:30:14AM +0100, Gil Portenseigne wrote:
>>>>> Hello,
>>>>>
>>>> Typo :And you should be able to : $ ./gradlew loadAll
>>
>


Mime
View raw message