ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <ju...@pacificshowerdoors.com>
Subject RE: Problem installing ofbiz
Date Sat, 08 Jun 2019 00:56:12 GMT
Many thanks to Jacques for stating what many would have found obvious, but
apparently not to me.

So I have now removed JAVA version 12 and installed "JDK1.8.0_211". I
followed a video tutorial that had me run several tests to verify the
installation including making a little program and I passed them all.
The following environmental variable entries currently exist:
1)	A path entry that reads "C:\Program Files (x86)\Common
Files\Oracle\Java\javapath". I verified that this was added during the
installation of JDK1.8.0_211. Also a path entry that reads "%JAVA_HOME%"
2)	a JAVA_HOME entry that reads " C:\Program
Files\Java\jdk1.8.0_211\bin". I used the browser option and this is indeed
where Java is kept, although there is another directory " C:\Program
Files\Java\jre1.8.0_211\bin" that was created during installation. Do I need
to set this up as well? If so, how?

When I try to run a command such as "gradlew cleanAll loadDefault" I get the
message " ERROR: JAVA_HOME is set to an invalid directory: C:\Program
Files\Java\jdk1.8.0_211\bin". But that makes no sense to me because that is
a valid directory and I did exactly what the tutorial instructed and
Java.exe is right there in that directory.

Sigh, what could I possibly be doing wrong now?


-----Original Message-----
From: Jacques Le Roux <jacques.le.roux@les7arts.com> 
Sent: 07 June 2019 01:52
To: user@ofbiz.apache.org
Subject: Re: Problem installing ofbiz

Hi Jules,

OFBiz only supports Java 8 so far.

Jacques

Le 07/06/2019 à 06:41, jules@pacificshowerdoors.com a écrit :
>
> I am unable to “initiate” ofbiz (16.11.05) on Windows 10 64 bit.
>
> I use the word initiate because I frankly do not know whether it is 
> installed or not because I do not know what to expect when I run various
gradlew commands.
>
> If memory serves, I started following either the instructions found at 
> https://cwiki.apache.org/confluence/display/OFBENDUSER/How+to+install+
> OFBiz+with+the+Demo+Data or those found at 
> https://cwiki.apache.org/confluence/display/OFBIZ/Demo+and+Test+Setup+
> Guide. It was not until later that I noticed the packed instructions 
> that came with the download. All of these instructions vary somewhat so
perhaps I started following outdated instructions. I also used other
instructions for ensuring that JAVA was correctly installed and have tried
other suggestions I could find from posts of others who had difficulties.
While not in any instruction, I also ran the packed batch file
“gradlew.bat”.
>
> Three things I clearly remember are:
>
>  1. One of the instructions I followed had hundreds, if not thousands, of
files installed, I know not where. I vaguely recall two numbers that kept
>     appearing just before adding another file…perhaps 44 and 45? I think
this was when I ran the batch file and I surmised it was installing sample
>     data.
>  2. Another instruction I followed, probably “gradlew LoadDefault ofbiz”,
or perhaps one of the other gradlew commands, would run for a bit showing
>     a number of successful operations before coming up with an error. I
think the error was along the lines that it could not find a jar file with
>     JAVA, which led me to try my best to fix the JAVA issue.
>  3. The second linked instruction talks about ensuring I have the right
flavour of JAVA installed (not JRE) and I found a post somewhere that talked
>     about deleting the wrong flavour, so that is what I did.
>
> At this point I tried again the various gradlew commands, but to no 
> avail. They ran in the sense that they did not produce any error messages,
but they did not show that anything happened either.
>
> If I understand the instructions, these gradlew commands merely 
> initiate some background processes (a opposed to bringing up a new 
> window) and that I need to sign in with a browser, hence the three links
that are included in the instructions such as
https://localhost:8443/accounting. When I follow those links I get the
message “unable to connect” in Firefox and “Hmmm...can’t reach this page” in
Microsoft Edge.
>
> Frustrated, I decided to start afresh. I deleted the folder with ofbiz and
reinstalled the software. The current situation is as follows:
>
>  1. Running the batch file causes a cmd window to briefly appear but
nothing else.
>  2. Running any gradlew commands returns no error codes but also no
actions.
>  3. The links do not work.
>
> I also found conflicting instructions on installing JAVA, or more to the
point, on setting the system variables. I finally followed this guide: 
> https://www.mkyong.com/java/how-to-set-java_home-on-windows-10/
>
> When I run the three tests at the end of that guide, “java -version” 
> and “javac -version” pass but “echo %JAVA_HOME%” merely echoes what I 
> typed instead of showing the location. I really did add a variable called
JAVA_HOME, browsing for the location to ensure against any spelling errors,
that location being C:\Program Files\Java\jdk-12.0.1.
>
> The following entries are present as environmental variables:
>
> C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;
>
> C:\Program Files (x86)\Intel\Intel(R) Management Engine 
> Components\iCLS\;
>
> C:\Program Files\Intel\Intel(R) Management Engine Components\iCLS\;
>
> %SystemRoot%\system32;
>
> %SystemRoot%;
>
> %SystemRoot%\System32\Wbem;
>
> %SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;
>
> %SYSTEMROOT%\System32\OpenSSH\;
>
> C:\Program Files (x86)\Intel\Intel(R) Management Engine 
> Components\DAL;
>
> C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;
>
> C:\Program Files (x86)\Intel\Intel(R) Management Engine 
> Components\IPT;
>
> C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;
>
> C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn\;
>
> C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\;
>
> C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;
>
> C:\Program Files\Microsoft SQL Server\120\DTS\Binn\;
>
> C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit\;
>
> C:\Program Files\Intel\WiFi\bin\;
>
> C:\Program Files\Common Files\Intel\WirelessCommon\;
>
> C:\Program Files\Java\jdk-12.0.1\bin;
>
> %JAVA_HOME%\bin;
>
> Closing thoughts:
>
> To some measure the conflicting installation instructions may be part 
> of the problem. Perhaps consideration should be given to replacing all 
> installation instructions with a simple notation to follow the “readme”
guide that comes packed with the download. That way there is only one set of
instructions to maintain and nobody will be left following an outdated
guide.
>
> If I can make it through this exercise I will volunteer to suggest 
> modifications to the embedded instructions such that a newbie such as
myself will be better able to follow them. I have a few ideas that might be
valuable.
>
> Many thanks
>
> Jules F. Wilkins, EMBA
>
> President, Pacific Shower Doors
>
> 2927 Norland Avenue, Burnaby, BC
> Office: 604-205-9444
> Cell: 778-834-9449
> PSD Logo whet style small for emails
>


Mime
View raw message