ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Mallah <mallah.raj...@gmail.com>
Subject Re: New Install won't run after server reboot
Date Wed, 09 May 2018 18:53:31 GMT
Hi ,

You must somehow start the ofbiz server after the server boots.
there are multitude of options for that. Eg systemd , daemontools etc.

After the system boots please check if a java program is listening @ 8443

eg by running $ sudo netstat -lnp

regds
mallah

On Wed, May 9, 2018 at 11:46 PM, drakesridge@gmail.com <
drakesridge@gmail.com> wrote:

> Hi All,
> I've just install ofbiz version 16.11.04 on a Centos 7 server. Everything
> seems to go very well and I was able to start the ofBiz web interface
> successfully, log in and navigate around.
>
> However, after I rebooted the server, I could not log in any longer. I
> suspected that it was a Java issue so I experimented with different Java
> versions and setups. I first built the server with and without JRE and the
> installation with just JDK seemed to be adequate. I then tried Java 8.131,
> Java 8.171 and Java 10.01. The first two worked as I described above
> (failing after a reboot) but Java version 10.01 failed during the install
> with a permissions problem while running the following step:
>
>  ./gradlew cleanAll loadDefault
>
> I'm sure I must be making a stupid mistake somewhere during the
> installation so would someone please look at the installations steps that I
> took to see where I went wrong?
>
> Here are the steps:
>
> Step 1 - Install Java
>         yum install -y jdk-8u131-linux-x64.rpm
>
>         export JAVA_HOME=/usr/java/jdk1.8.0_131
>
>         export PATH=$PATH:/usr/java/jdk1.8.0_131/bin
>
>         Check Java JDK Version:
>                 java -version
>
> Step 2 - Load environmental variables on startup
>         echo 'export JAVA_HOME=/usr/java/jdk1.8.0_131' >> /etc/bashrc
>
>         echo 'export PATH=$PATH:/usr/java/jdk1.8.0_131/bin' >> /etc/bashrc
>
> Step 3 - Open port on firewall
>         firewall-cmd - -zone=public - -add-port=8443/tcp - -permanent
>
>         firewall-cmd - -reload
>
> Step 4 - Setup ofBiz
>         unzip apache-ofbiz-16.11.04.zip
>
>         mv apache-ofbiz-16.11.04 /usr/local/ofbiz
>
> Step 5 - Install ofBiz
>         cd /usr/local/ofbiz
>
>         ./gradlew cleanAll loadDefault
>
>         ./gradlew "ofbiz --load-data readers=seed"
>
>         ./gradlew "ofbiz --load-data readers=seed,seed-initial,ext"
>
> Step 6 - Start ofBiz
>         ./gradlew ofbizBackground
>
> Step 7 - Access ofBiz in browser
>
>         URL:  https://<my IP>:8443/myportal/control/main
>
>         Admin Username: admin
>
>         Admin Password: ofbiz
>
> Additional notes:
>
> after I reboot and can't restart the web interface, if I run ./gradlew
> "ofbiz --status" , it reports that obBiz is running OK
>
> I'm really not sure what I'm doing wrong so any tips and suggestions will
> be very much appreciated
>
> Regards,
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message