ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "pierre.gaudin" <pierre.gau...@nereide.fr>
Subject Re: Sending mail from Ofbiz does not work
Date Mon, 12 Feb 2018 20:32:12 GMT
Also, have a look at SystemProperty entity for key 
mail.notifications.enabled

Pierre

On 12/02/2018 19:53, Mike wrote:
> For TLS (mail.smtp.starttls.enable=true ), use port 587
>
> On Mon, Feb 12, 2018 at 4:37 AM, Дмитрий Цыганок <dt@kapitanweb.ru>
wrote:
>
>> Hello!
>> I've deployed Ofbiz several times, but each time with the right settings,
>> email notifications are not sent.
>>
>> Here are my settings from /var/www/ofbiz/framework/common/config/general.
>> properties:
>>
>> unique.instanceId=ofbiz1
>> currency.uom.id.default=USD
>> ORGANIZATION_PARTY=Company
>> VISUAL_THEME=RAINBOWSTONE_SAPHIR
>> currency.decimal.format=#,##0.00
>> currency.rounding.default=10
>> currency.scale.enabled=N
>> locale.properties.fallback=en
>> #locales.available=ar,de,en,es,fr,hi,it,nl,pt,ro,ru,th,zh
>> #timeZones.available=US/Eastern,US/Central,US/
>> Mountain,US/Pacific,US/Alaska,US/Hawaii
>> country.geo.id.default=USA
>> partner.trackingCodeId.default=
>> usps.address.match=(^.*?p[\\. ]*o[\\. ]*box.*$)|(^.*?post.*?office.*?box.*$)|((^|(^.*?
>> ))r[\\. ]*r[\\. ]*(( +)|([0-9#]+)).*$)|(^.*?rural.*?route.*$)
>> defaultFromEmailAddress=dmtsyganok@gmail.com
>> mail.notifications.enabled=Y
>> mail.notifications.redirectTo=dt@kapitanweb.ru
>> mail.smtp.relay.host=smtp.gmail.com
>> mail.smtp.auth.user=dmtsyganok@gmail.com
>> mail.smtp.auth.password=*******
>> mail.smtp.port=465
>> mail.smtp.starttls.enable=true
>> mail.smtp.socketFactory.port=465
>> mail.smtp.socketFactory.class=javax.net.ssl.SSLSocketFactory
>> mail.smtp.socketFactory.fallback=false
>> mail.address.caseInsensitive=N
>> mail.debug.on=N
>> mail.smtp.sendpartial=true
>> http.upload.max.sizethreshold=10240
>> http.upload.tmprepository=runtime/tmp
>> http.upload.max.size=-1
>> mail.spam.name=X-Spam-Flag
>> mail.spam.value=YES
>> Ofbiz always issues this error in the logs and the mail is not sent:
>>
>> " 2018-01-17 22:21:19,562 |OFBiz-JobQueue-1     |EmailServices
>>       |I| Mail notifications disabled in general.properties; mail with
>> subject [test] not sent to addressee [ dt@kapitanweb.ru   "
>>
>>
>> I also tried different mail accounts, but the result is always the same.
>>
>> What could be the reason? Please help me to solve this problem.
>> Thank you very much in advance!
>>
>> ---
>> Best Regards,
>> Dmitriy
>>
>>


Mime
View raw message