ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boyden, Timothy" <tboy...@Electroswitch.com>
Subject RE: Cannot install apache-ofbiz-16.11.03 on windows 10
Date Fri, 22 Dec 2017 17:43:20 GMT
List of docs that reference OFBIZ_HOME:

https://cwiki.apache.org/confluence/dosearchsite.action?where=OFBIZ&spaceSearch=true&queryString=OFBIZ_HOME

-Tim

-----Original Message-----
From: Boyden, Timothy [mailto:tboyden@Electroswitch.com] 
Sent: Friday, December 22, 2017 12:42 PM
To: user@ofbiz.apache.org
Subject: RE: Cannot install apache-ofbiz-16.11.03 on windows 10

I guess it's not needed, but ran across some documents on ofbiz.apache.org that recommend
setting it.

-Tim

-----Original Message-----
From: Jacques Le Roux [mailto:jacques.le.roux@les7arts.com]
Sent: Friday, December 22, 2017 12:04 PM
To: user@ofbiz.apache.org
Subject: Re: Cannot install apache-ofbiz-16.11.03 on windows 10

Hi Tim,

Why do you define OFBIZ_HOME?

Jacques


Le 22/12/2017 à 17:25, Boyden, Timothy a écrit :
> Hi Christian,
>
> Did you try setting environment variables for JAVA_HOME and OFBIZ_HOME?
>
> https://www.mkyong.com/java/how-to-set-java_home-on-windows-10/
>
> Follow the instructions in the above to set:
>
> JAVA_HOME = C:\Program Files\Java\jdk1.8.0_151 OFBIZ_HOME =
> C:\apache-ofbiz-16.11.03
>
> Make sure the bin folder is in the root of C:\Program Files\Java\jdk1.8.0_151.
>
> Make sure the application, framework, etc... folders are in the root of C:\apache-ofbiz-16.11.03.
>
> Then try recompiling.
>
> -Tim
>
>
> -----Original Message-----
> From: Christian Vetterli [mailto:purduealumni@gmx.ch]
> Sent: Friday, December 22, 2017 8:59 AM
> To: user@ofbiz.apache.org
> Subject: Cannot install apache-ofbiz-16.11.03 on windows 10
>
> Hello all,
> I do not get OFBiz istalled on my Windows 10 computer. I have tried any combination I
could come up with. Different loading locations. All currently available Java versions from
Oracle. Nothing seem to work. I am not a programmer.
>   
> What I did for example is:
> OFBiz to C:\apache-ofbiz-16.11.03
> Java to C:\Program Files\Java\jdk1.8.0_151 and C:\Program
> Files\Java\jre1.8.0_151
>   
> I used the commands gradlew cleanAll loadDefault or gradlew loadDefault ofbiz and I tried
to change locations for OFBiz and Java. In addition, I tried the latest version of Java.
> All I am getting is:
>   
> C:\apache-ofbiz-16.11.03>gradlew cleanAll loadDefault :clean :cleanAnt 
> :cleanCatalina :cleanData :cleanDownloads :cleanEclipseClasspath 
> UP-TO-DATE :cleanEclipseJdt UP-TO-DATE :cleanEclipseProject UP-TO-DATE 
> :cleanEclipse UP-TO-DATE :cleanFooterFiles :cleanGradle :cleanIndexes 
> :cleanLogs :cleanOutput :cleanTempfiles :cleanUploads :cleanXtra 
> :cleanAll :compileJava
> Note: Some input files use unchecked or unsafe operations.
> Note: Recompile with -Xlint:unchecked for details.
> :processResources
> :classes
> :jar
> :assemble
> :compileTestJava
> :processTestResources UP-TO-DATE
> :testClasses
> :test
> :check
> :build
> :ofbiz --load-data
>   
> Exception in thread "main" java.lang.NoClassDefFoundError: 
> org/apache/commons/cli/ParseException
> at org.apache.ofbiz.base.start.Start.main(Start.java:60)
> Caused by: java.lang.ClassNotFoundException: 
> org.apache.commons.cli.ParseException
> at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:335)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
> ... 1 more
> :ofbiz --load-data FAILED
>   
> FAILURE: Build failed with an exception.
>   
> * What went wrong:
> Execution failed for task ':ofbiz --load-data'.
>> Process 'command 'C:\Program Files\Java\jdk1.8.0_151\bin\java.exe''
>> finished with non-zero exit value 1
>   
> * Try:
> Run with --stacktrace option to get the stack trace. Run with --info or --debug option
to get more log output.
>   
> BUILD FAILED
>   
> Total time: 2 mins 54.909 secs
>   
> C:\apache-ofbiz-16.11.03>
>   
> It seems that there might be a problem with windows 10.
> Does someone have a solution?
> Thanks a lot.
> Greetings from Switzerland,
> Christian

Mime
View raw message