ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacques Le Roux <jacques.le.r...@les7arts.com>
Subject Re: Can't access webapp in debug model
Date Tue, 27 Jun 2017 15:58:01 GMT
I did not feel any arrogance. I just wanted to explain :)

Jacques


Le 27/06/2017 à 15:42, Daniel Coric a écrit :
> Hi Jacques,
>
> I just realized that my questions could sound arrogant - I must say, that wasn't my attention.
> Thank you very much for these explanations - the picture is now much clearer to me.
>
> Regards,
> Daniel
>
> On 2017-06-27 15:20 (+0200), Jacques Le Roux <jacques.le.roux@les7arts.com> wrote:
>> To be complete, forgot to say that some ASF Top Level Projects (TLP) are only using
Git and have no SVN branches. It's often new projects out of ASF
>> Incubator (was 11 years ago for OFBiz...)
>>
>> At some point in the future the ASF will no longer use Githup for its Git repos but
an internal GitBox. It's already the case for some projects, but
>> not OFBiz.
>>
>> Some links:
>>
>> https://git.apache.org/
>>
>> https://gitbox.apache.org/
>>
>> Jacques
>>
>>
>> Le 27/06/2017 à 14:35, Jacques Le Roux a écrit :
>>> It's not against ASF policy to use Git for OFBiz. It's just unofficial and may
be a bit out of date sometimes (rarely now - if ever, happened more
>>> in the past)
>>>
>>> For instance, using "Switch branches/tags" Github feature, you can clone  R16.11
branch from https://github.com/apache/ofbiz/tree/release16.11 (I
>>> guess you did that)
>>>
>>> We have not yet released the new structure (framework+plugins), one headache
less for now ;)
>>>
>>> HTH
>>>
>>> Jacques
>>>
>>>
>>> Le 26/06/2017 à 21:02, Daniel Coric a écrit :
>>>> And this, just saw it, "There is no Git repo for the branches which support
the released packages, but there are SVN repos at".
>>>> Is it against ASF policy to use GIT or what?! I don't understand.
>>>>
>>>> On 2017-06-26 20:57 (+0200), "Daniel Coric"<coric75@gmail.com> wrote:
>>>>> Hi Jacques,
>>>>>
>>>>> thanks.
>>>>>
>>>>> I just saw that you have corrected the "Using GIT from within Eclipse"
- wanted to recommend the article to Vy.
>>>>> How do you mean "Freezed just before the framework and plugins split,
12 Feb 2017"?
>>>>> I have cloned release16.11 from the very same URL just before I have
wrote that part.
>>>>>
>>>>> Regards,
>>>>> Daniel
>>>>>
>>>>> On 2017-06-26 20:34 (+0200), Jacques Le Roux <jacques.le.roux@les7arts.com>
wrote:
>>>>>> Well spotted Daniel,
>>>>>>
>>>>>> Vy, if you run "gradlew eclipse" it will generate the .project and
.classpath files which are used by Eclipse to handle OFBiz
>>>>>>
>>>>>> So it seems you just miss that...
>>>>>>
>>>>>> Jacques
>>>>>>
>>>>>>
>>>>>> Le 26/06/2017 à 20:23, Daniel Coric a écrit
:
>>>>>>> Hi Vy,
>>>>>>>
>>>>>>> it's pretty clear if you look a bit closely in the Project Explorer
at this image
>>>>>>> https://user-images.githubusercontent.com/1328316/27529985-cf1d158a-5a80-11e7-865f-581a353b94d2.jpg.
>>>>>>> You have only empty directory "ofbiz". That means that you cannot
have one more project under the same name. What again means that you don't
>>>>>>> have a project "ofbiz" at all.
>>>>>>> And, why are these other maven?! How did you import the project?
>>>>>>>
>>>>>>> Regards,
>>>>>>> Daniel
>>>>>>>
>>>>>>> On 2017-06-26 10:27 (+0200), Donhu Vy <donhuvy@hotmail.com>
wrote:
>>>>>>>>> Did you run gradlew eclipse?
>>>>>>>> --> I release all Gradle-related commands from CMD.
>>>>>>>>
>>>>>>>> ________________________________
>>>>>>>> From: Taher Alkhateeb <slidingfilaments@gmail.com>
>>>>>>>> Sent: Monday, June 26, 2017 3:22:35 PM
>>>>>>>> To: user@ofbiz.apache.org
>>>>>>>> Subject: Re: Can't access webapp in debug model
>>>>>>>>
>>>>>>>> Did you run gradlew eclipse?
>>>>>>>>
>>>>>>>> On Jun 26, 2017 11:15 AM, "Donhu Vy" <donhuvy@hotmail.com>
wrote:
>>>>>>>>
>>>>>>>>> I try to clean all things.
>>>>>>>>> gradlew cleanAll loadDefault
>>>>>>>>>
>>>>>>>>> Indeed, At the previous session, I didn't set anything
in tab Source. This
>>>>>>>>> session, I set it (like screenshot https://user-images.
>>>>>>>>> githubusercontent.com/1328316/27529984-cf1c13e2-5a80-11e7-
>>>>>>>>> 8277-9cfc20fed94d.jpg )
>>>>>>>>>
>>>>>>>>> Tab Connect still like previous session (https://user-images.
>>>>>>>>> githubusercontent.com/1328316/27529985-cf1d158a-5a80-11e7-
>>>>>>>>> 865f-581a353b94d2.jpg )
>>>>>>>>> In CMD, Then I release command:
>>>>>>>>> gradlew ofbizDebug
>>>>>>>>>
>>>>>>>>> CMD console log has nothing. Console screen inside Eclipse
IDE also has
>>>>>>>>> nothing.
>>>>>>>>>
>>>>>>>>> Error still looks like previous session (https://user-images.
>>>>>>>>> githubusercontent.com/1328316/27529986-cfbca74e-5a80-11e7-
>>>>>>>>> 8c4f-10ba778c94e0.jpg)
>>>>>>>>>
>>>>>>>>> This is my Eclipse log https://gist.github.com/donhuvy/
>>>>>>>>> fbf6037ffd941a95729614b056764758 (File .log inside .metadata
folder)
>>>>>>>>>
>>>>>>>>> Help me debug OFBiz!
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> ________________________________
>>>>>>>>> From: Jacques Le Roux <jacques.le.roux@les7arts.com>
>>>>>>>>> Sent: Monday, June 26, 2017 2:50:01 PM
>>>>>>>>> To: user@ofbiz.apache.org
>>>>>>>>> Subject: Re: Can't access webapp in debug model
>>>>>>>>>
>>>>>>>>> Vy,
>>>>>>>>>
>>>>>>>>> I don't see what could be missing, seems to be an issue
with your debug
>>>>>>>>> config.
>>>>>>>>>
>>>>>>>>> Did you set correctly the Debug Source tab (near Connect
tab)?
>>>>>>>>>
>>>>>>>>> Do you see something in the OFBiz console or console.log?
>>>>>>>>>
>>>>>>>>> Did you check the Eclipse log?
>>>>>>>>>
>>>>>>>>> Jacques
>>>>>>>>>
>>>>>>>>> Le 26/06/2017 Ã  09:19, Donhu Vy a
écrit :
>>>>>>>>>> Thank Jacques Le Roux,
>>>>>>>>>>
>>>>>>>>>> I don't understand your reply. I want re-present
my work step-by-step.
>>>>>>>>>>
>>>>>>>>>> I am reading https://cwiki.apache.org/confluence/display/OFBIZ/
>>>>>>>>> Running+and+Debugging+OFBiz+in+Eclipse . I am using Windows
10 Pro x64,
>>>>>>>>> Eclipse Neon 3.
>>>>>>>>>>      At OFBiz's folder (F:\ofbiz), I release command
>>>>>>>>>>
>>>>>>>>>> gradlew ofbizDebug
>>>>>>>>>>
>>>>>>>>>> (screenshot: https://user-images.githubusercontent.com/1328316/
>>>>>>>>> 27528187-72519bca-5a79-11e7-8bd2-e4d3751642f7.jpg )
>>>>>>>>>> At Debug configuration windows, I set configuration
like screenshot
>>>>>>>>> https://user-images.githubusercontent.com/1328316/
>>>>>>>>> 27528188-7276fc1c-5a79-11e7-846c-85d75b037f5d.jpg
>>>>>>>>>> When I press button "Debug", I see error:
>>>>>>>>>> Problem Occurred
>>>>>>>>>> 'Launching gradle_remote_debug' has encountered a
problem. Launch
>>>>>>>>> configuration gradle_remote_debug references closed project
ofbiz.
>>>>>>>>>> Details: Launch configuration gradle_remote_debug
references closed
>>>>>>>>> project ofbiz
>>>>>>>>>> (Screenshot: https://user-images.githubusercontent.com/1328316/
>>>>>>>>> 27528317-19ce76c0-5a7a-11e7-9635-e0e38adb07ca.jpg )
>>>>>>>>>> How to debug OFBiz inside Eclipse IDE?
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Vy
>>>>>>>>>>
>>>>>>>>>> ________________________________
>>>>>>>>>> From: Jacques Le Roux <jacques.le.roux@les7arts.com>
>>>>>>>>>> Sent: Monday, June 26, 2017 1:32:39 PM
>>>>>>>>>> To: user@ofbiz.apache.org
>>>>>>>>>> Subject: Re: Can't access webapp in debug model
>>>>>>>>>>
>>>>>>>>>> Hi,
>>>>>>>>>>
>>>>>>>>>> You need to start a debugger for OFBiz to continue
and be ready.
>>>>>>>>>>
>>>>>>>>>> When you use the ofbizDebug Gradle task, OFBiz waits
for a debugger to
>>>>>>>>> continue. You can see that in the console or console.log
>>>>>>>>>> Jacques
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Le 26/06/2017 Ã  04:14, Donhu Vy
a écrit :
>>>>>>>>>>> In previous sessions, when I release command
>>>>>>>>>>> gradlew cleanAll loadDefault ofbiz --info
>>>>>>>>>>> I can access https://localhost:8443/ap/control/main
and start to play
>>>>>>>>> with OFBiz.
>>>>>>>>>>> Today , I release command
>>>>>>>>>>> gradlew cleanAll loadDefault ofbizDebug --info
>>>>>>>>>>> I can't access https://localhost:8443/ap/control/main
.
>>>>>>>>>>>
>>>>>>>>>>> Please help me explain why. I want dive inside
to source code and start
>>>>>>>>> make something small (for example: a widget, or tweak
few lines of code).
>>>
>>


Mime
View raw message