ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leonard Lin" <leonard....@gmx.net>
Subject Aw: Re: 16.11 ofbizUrl break some reverse-proxy / docker setups
Date Mon, 20 Feb 2017 19:11:59 GMT
Hi Jacques,

I created the ticket: https://issues.apache.org/jira/browse/OFBIZ-9224

Thanks in advance for any help.

Best
Leonard
 
 

Gesendet: Montag, 20. Februar 2017 um 09:13 Uhr
Von: "Jacques Le Roux" <jacques.le.roux@les7arts.com>
An: user@ofbiz.apache.org
Betreff: Re: 16.11 ofbizUrl break some reverse-proxy / docker setups
Thanks Leonard,

Please open a Jira issue with the same than below. It seems related to an issue we have also
on demo to deploy certificate but we did not open a Jira
yet. I'll have a look ASAP.

Thanks

Jacques


Le 20/02/2017 à 00:23, Leonard Lin a écrit :
> Hi,
>
> I was just to deploy 16.11 version (moving up from 15) and noticed that the url-behaviour
changed.
>
> This can be reproduced on the official ofbiz-demo site:
>
> - Go to http://ofbiz.apache.org/
> - Open the Ofbiz 13.07 Demo (Management Apps)
> - - it will auto-login for your, do a logout so that you can see the login-mask
> - - look at the HTML code and look for the form-post url etc. You can see that none of
the URLs include hostname:port. They are all "/url/path"
>
> - Open the Ofbiz 16.11 Demo (Management Apps)
> - - it will auto-login for your, do a logout so that you can see the login-mask
> - - look at the HTML code and look for the form-post url etc.
> - - the post-urls and login-links have format: https://hostname:port/url/path
>
> The new 16.11 behaviour cases problems in my setup because I deploy ofbiz in a cluster
/ docker image where actual host:port do not match public-host:port
>
> Before 16.11 this was not an issue because all links were without hostname:port. But
now the login masks loads but the subsequent links all show the wrong port.
>
> I tried to look in the code for the change but couldn't figure it out.
>
> url.properties seems to control port/hostname but I prefer to to set it at all and keep
the old behaviour.
>
> Is this a setting - change or an actual logic?
>
> Any help is greatly appreciated.
>
> Thanks
> Leonard
>
 

Mime
View raw message