ofbiz-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mike Butler <mike-but...@outlook.com>
Subject RE: createComponent task not in ofbiz16.11
Date Sun, 19 Feb 2017 19:05:10 GMT
Hi Jacques.

I  used the command line only.
Tried with eclipse open (not editing) and closed so there should have been no problem there.
Not debugging yet in eclipse just viewing source.

Also I have the same problem in both Edge and Chrome browsers so that more or less eliminates
a browser problem.


From: Jacques Le Roux<mailto:jacques.le.roux@les7arts.com>
Sent: 19 February 2017 17:34
To: user@ofbiz.apache.org<mailto:user@ofbiz.apache.org>
Subject: Re: createComponent task not in ofbiz16.11

You can get this error when running OFBiz in Eclipse https://cwiki.apache.org/confluence/display/OFBIZ/Running+and+Debugging+OFBiz+in+Eclipse

AFAIK not when using a cmd line (Win) or terminal (*nix). I also use Windows (7), but I must
say I tried to create a component but I don't remember if
I used the component URL...

Jacques


Le 19/02/2017 à 16:41, mike Butler a écrit :
> Thanks all.  Looks like something system dependent.
> I am using windows 10 on 64bit i7 processor.
>
> I will try on a Linux virtual machine
>
>
> From: Michael Brohl<mailto:michael.brohl@ecomify.de>
> Sent: 19 February 2017 15:52
> To: user@ofbiz.apache.org<mailto:user@ofbiz.apache.org>
> Subject: Re: createComponent task not in ofbiz16.11
>
> Just checked it also:
>
> ./gradlew createPlugin -PpluginId=ofbizdemo
>
> ./gradlew ofbiz
>
> Did not reload data, so cannot login, but get a login screen and no errors.
>
> I vaguely remember we had a similar report some time ago but cannot find
> it in dev, user mailing lists or Jira.
>
> Strange...
>
> Regards,
>
> Michael
>
>
> Am 19.02.17 um 15:47 schrieb Taher Alkhateeb:
>> gradlew createPlugin -PpluginId=ofbizdemo followed by gradlew cleanAll
>> loadDefault and then started ofbiz and went to /ofbizdemo .. I login and
>> then get redirected to an empty page. Nothing crashed on screen. This is on
>> trunk
>>
>> On Feb 19, 2017 5:35 PM, "mike Butler" <mike-butler@outlook.com> wrote:
>>
>>> Changed local to Germany. Same problem.
>>>
>>> Have you got the same problem when createPlugin in trunk?  Just to exclude
>>> any problem on my local machine.
>>>
>>> Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for
>>> Windows 10
>>>
>>> From: Taher Alkhateeb<mailto:slidingfilaments@gmail.com>
>>> Sent: 19 February 2017 14:51
>>> To: user@ofbiz.apache.org<mailto:user@ofbiz.apache.org>
>>> Subject: Re: createComponent task not in ofbiz16.11
>>>
>>> hmm, then there is a bug elsewhere I think. Try changing the locale, would
>>> that work? if yes, then file a new issue in
>>> https://issues.apache.org/jira/browse/OFBIZ
>>>
>>> On Sun, Feb 19, 2017 at 4:46 PM, mike Butler <mike-butler@outlook.com>
>>> wrote:
>>>
>>>> Hi Taher
>>>>
>>>> Tried trunk as well – still get the same “locale [en_GB]” error displayed
>>>> in the browser when running https://localhost:8443/ofbizdemo (which
>>>> defaults to https://localhost:8443/ofbizdemo/control/main
>>>> So that is working ok)
>>>>
>>>> Simple command: gradlew createPlugin -PpluginId=ofbizdemo
>>>> Restarted ofbiz : gradlew ofbiz : then the above url -> locale [en_GB]
>>>> error screen
>>>> Stopped ofbiz: then gradlew cleanAll loadDefault: gradlew ofbiz:  same
>>>> locale [en_GB] error screen
>>>> Would be interesting to see if you get the same.
>>>>
>>>> Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for
>>>> Windows 10
>>>>
>>>> From: Taher Alkhateeb<mailto:slidingfilaments@gmail.com>
>>>> Sent: 19 February 2017 09:28
>>>> To: user@ofbiz.apache.org<mailto:user@ofbiz.apache.org>
>>>> Subject: Re: createComponent task not in ofbiz16.11
>>>>
>>>> Hello Mike,
>>>>
>>>> What was the command you used to create the plugin? I ran the command in
>>>> trunk and see the new webapp working fine.
>>>>
>>>> Cheers,
>>>>
>>>> Taher Alkhateeb
>>>>
>>>> On Sat, Feb 18, 2017 at 8:35 PM, mike Butler <mike-butler@outlook.com>
>>>> wrote:
>>>>
>>>>> Thank Jacques
>>>>>
>>>>> Created plugin OK.
>>>>> Ran gradlew  cleanAll loadDefault
>>>>> Ran gradlew ofbiz
>>>>>
>>>>> All OK however when running https://localhost:8443/
>>>> ofbizdemo/control/main
>>>>> I get error:
>>>>>
>>>>> org.apache.ofbiz.widget.renderer.ScreenRenderException: Error
>>> rendering
>>>>> screen [component://common/widget/CommonScreens.xml#login]:
>>>>> org.apache.ofbiz.widget.renderer.ScreenRenderException: Error
>>> rendering
>>>>> screen [component://ofbizdemo/widget/CommonScreens.xml#main-
>>> decorator]:
>>>>> java.lang.IllegalArgumentException: Could not find resource bundle
>>>>> [OfbizdemoUiLabels] in the locale [en_GB] (Could not find resource
>>> bundle
>>>>> [OfbizdemoUiLabels] in the locale [en_GB]) (Error rendering screen
>>>>> [component://ofbizdemo/widget/CommonScreens.xml#main-decorator]:
>>>>> java.lang.IllegalArgumentException: Could not find resource bundle
>>>>> [OfbizdemoUiLabels] in the locale [en_GB] (Could not find resource
>>> bundle
>>>>> [OfbizdemoUiLabels] in the locale [en_GB]))
>>>>>
>>>>> Any ideas how to fix?
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986>
for
>>>>> Windows 10
>>>>>
>>>>> From: Jacques Le Roux<mailto:jacques.le.roux@les7arts.com>
>>>>> Sent: 18 February 2017 13:23
>>>>> To: user@ofbiz.apache.org<mailto:user@ofbiz.apache.org>
>>>>> Subject: Re: createComponent task not in ofbiz16.11
>>>>>
>>>>> There is also this wiki page mostly based on the main README.md but
>>> with
>>>>> some migration advices and such
>>>>>
>>>>> https://cwiki.apache.org/confluence/display/OFBIZ/From+Ant+to+Gradle
>>>>>
>>>>> Jacques
>>>>>
>>>>>
>>>>> Le 18/02/2017 à 12:45, mike Butler a écrit :
>>>>>> Great. Thanks
>>>>>>
>>>>>>
>>>>>> Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986>
for
>>>>> Windows 10
>>>>>> From: Taher Alkhateeb<mailto:slidingfilaments@gmail.com>
>>>>>> Sent: 18 February 2017 12:35
>>>>>> To: user@ofbiz.apache.org<mailto:user@ofbiz.apache.org>
>>>>>> Subject: Re: createComponent task not in ofbiz16.11
>>>>>>
>>>>>> Yeah the plugins should probably replace hot-deploy but in your
>>>> release.
>>>>>> This is still on-going in trunk.
>>>>>>
>>>>>> The detailed documentation that you need is available in README.md
at
>>>> the
>>>>>> top level directory.
>>>>>>
>>>>>> On Sat, Feb 18, 2017 at 2:27 PM, mike Butler <
>>> mike-butler@outlook.com>
>>>>>> wrote:
>>>>>>
>>>>>>> Thanks for prompt reply
>>>>>>>
>>>>>>> Are plugins intended to replace hot-deploy components or will
>>>>>>> createComponent be reintroduced.
>>>>>>>
>>>>>>> What is the format for createPlugin task.  Nothing found in user
>>>>>>> documentation!
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986>
for
>>>>>>> Windows 10
>>>>>>>
>>>>>>> From: Taher Alkhateeb<mailto:slidingfilaments@gmail.com>
>>>>>>> Sent: 18 February 2017 12:08
>>>>>>> To: user@ofbiz.apache.org<mailto:user@ofbiz.apache.org>
>>>>>>> Subject: Re: createComponent task not in ofbiz16.11
>>>>>>>
>>>>>>> Hello mike. Yeah the alternative is to call the task createPlugin.
>>> It
>>>>> would
>>>>>>> do the same thing but create the component in /specialpurpose
and
>>> add
>>>>> it to
>>>>>>> component-load.xml. This was due to the transitional switch to
>>> plugins
>>>>>>> (long story)
>>>>>>>
>>>>>>> On Sat, Feb 18, 2017 at 2:05 PM, mike Butler <
>>> mike-butler@outlook.com
>>>>>>> wrote:
>>>>>>>
>>>>>>>> I have installed Ofbiz16.11 and want to use the createComponent
>>> task
>>>>> but
>>>>>>> I
>>>>>>>> get 'createComponent' not found in root project 'ofbiz' and
when I
>>>>>>> ‘gradlew
>>>>>>>> tasks’ or gradlew tasks –all, createComponent it is not
in the list
>>>>>>>> returned.
>>>>>>>>
>>>>>>>> I cannot find anything in the archives about this.
>>>>>>>> Has the command been removed?
>>>>>>>>
>>>>>>>>
>
>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message